Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 23rd May 2013, 16:13
sixone sixone is offline
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question ISPconfig 3 mail loops back to myself

Hi

I installed ISPconfig 3 with Courier IMAP/POP3 and maildrop a while ago. Everything was fine, until i noticed that mail filters (like filtering junk or autoresponder) is not working because relay was 'virtual' not 'maildrop'.
I changed it to 'maildrop', filtering is working, but aliases or forwarding are not working anymore.
Now maildrop / postfix is not checking virtual aliases in mysql, it says something with permission denied, user does not exists, which is kinda true, cause there's no file/folder in /var/vmail for that user, it's an alias in mysql forward table.

So, my dilemma is how can i get both of them working, aliases and maildrop filtering?

right now i have this config:
..
virtual_transport = maildrop
best_mx_transport = virtual
..
changes were made to best_mx_transport from virtual to maildrop
if i comment out the best_mx_tranport or delete it, i get an error, mail looks back to myself.
domain to which i'm trying to send email and get the error does exists in domain table, it's working if i set it to virtual or maildrop.

hope that makes sens

Last edited by sixone; 23rd May 2013 at 16:24.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 23:58
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 21:01
Undelivered Mail Returned to Sender djmixx07 Server Operation 27 18th June 2010 13:57
Why did Squirrelmail, Dovecot/IMAP & Outbound mail break? websissy Technical 4 29th October 2009 23:39
problem with mail server setup kentor HOWTO-Related Questions 27 16th July 2009 16:22


All times are GMT +2. The time now is 15:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.