Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd May 2013, 01:13
suicid3 suicid3 is offline
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default The Perfect Server Ubuntu 13.04 - static IP and Hostname

I'll try to detail as much as possible of my current setup.
I have a Cisco E2500 Router running off of the Cable Modem set to 192.168.1.1
I have a Repeater Bridge Linksys WRT54G connected to the Cisco wirelessly, with the IP 192.168.1.2
IP range on the Cisco is 128 (192.168.1.100-192.168.1.128)

My server is connected to the Linksys on IP 192.168.1.150 DHCP
I tried to enable static IP with the following settings:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.150
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 8.8.8.8 8.8.4.4

then i run
/etc/init.d/networking restart
gives errors, but all is well, still connected.

then I go to next step and edit hosts file to

127.0.0.1 localhost.localdomain local
192.168.1.150 myserver.mydomain.com
save and exit

then
echo myserver.mydomain.com > /etc/hostname
/etc/init.d/hostname restart
all well

hostname
returns myserver.mydomain.com
hostname -f
returns myserver.mydomain.com

apt-get update
apt-get upgrade
reboot

Then configuring virtual network devices - Fail
starting without full network config
no network
eth0 shows no IP
and I get the error when using sudo
"unable to resolve host myserver.mydomain.com

Not Sure what I'm missing here......................
Thank you in advance to all the Guru's
__________________
Owner - www.urbanassaultcellular.com

Linux, Windows, Android, Mac OSX enthusiast
Cellphone GuruGeek - "The Phone Whisperer"

Network - Cisco E2500 Primary Router, Linksys WRT64 DD-WRT Repeater Bridge
Toy Server - Pentium 4 HT 3.1GHz, 4Gb DDR2, 80Gb Western Digital, 80Gb Maxtor
Workstation - 500GB Western Digital, 500GB Hitachi, 200GB Western Digital, 1TB Maxtor, 8GB OC2 Platinum DDR2 1066 PC2 8500, ASUS m3a79-t Deluxe MoBo, AMD Phenom AM2+ Quad Core 2.3GHz, (2) ATI 5700HD w/CrossFire.

Last edited by suicid3; 22nd May 2013 at 05:11.
Reply With Quote
Sponsored Links
  #2  
Old 22nd May 2013, 09:01
suicid3 suicid3 is offline
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default SOLVED - maybe?

I think I found the answer

I installed CentOS bare minimum just to play with / view settings.
Turns out since I'm behind a repeater simply adding the google public DNS didn't allow me to resolve within my network to the host router. By adding the local nameserver from the host router

dns-nameservers 8.8.8.8 75.75.75.75

It seemed to connect and stay connected.
Also editing
/etc/sysconfig/network-scripts/ifcfg-eth0
from
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=no
to
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes
Made it come back to life.
Haven't attempted this in Ubuntu Server yet, but I'll report back
__________________
Owner - www.urbanassaultcellular.com

Linux, Windows, Android, Mac OSX enthusiast
Cellphone GuruGeek - "The Phone Whisperer"

Network - Cisco E2500 Primary Router, Linksys WRT64 DD-WRT Repeater Bridge
Toy Server - Pentium 4 HT 3.1GHz, 4Gb DDR2, 80Gb Western Digital, 80Gb Maxtor
Workstation - 500GB Western Digital, 500GB Hitachi, 200GB Western Digital, 1TB Maxtor, 8GB OC2 Platinum DDR2 1066 PC2 8500, ASUS m3a79-t Deluxe MoBo, AMD Phenom AM2+ Quad Core 2.3GHz, (2) ATI 5700HD w/CrossFire.
Reply With Quote
Reply

Bookmarks

Tags
hostname, repeater bridge, static ip, thye perfect server, ubuntu server 13.04

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 20:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.