Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > ISPConfig 3 Priority Support

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th May 2013, 23:39
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 420
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default multiserver - problem with db password for remote user

Hello,
this is not question of priority support but problem with mysql_clientdb_plugin.inc.php in multiserver setup.

i have reported here: http://bugtracker.ispconfig.org/inde...opened=54&type[0]=&sev[0]=&due[0]=&cat[0]=&status[0]=open&percent[0]=&reported[0]=
but my post was long and maybe nobody have read it untill last comment where error is desribed:

---
Problem appears in multiserver setup when you change db user password and after it you change IP acces configuration for remote DB user

when database user password is changed in gui:
it gets changed in master ispconfig database in web_database_user,
passwords for both users (local and remote) in mysql user table on remote server are created correctly

But PASSWORD IN DATABASE ON SLAVE SERVER web_database_user table IS NOT CHANGED - is created new row with sys_userid and sys_groupid both set to 0
This new duplicate rows are overwrited when next db user is created and master db synced to slave server (but old password for remote user in slave web_database_user stays forever..)

Then when acces to db is changed IP<->% or another ip added, password for remote user is probably taken from this slave web_database_user and it is set wrongly in mysql user table, so remote access is not working then

Last edited by radim_h; 5th May 2013 at 23:48.
Reply With Quote
Sponsored Links
  #2  
Old 6th May 2013, 10:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Hi,

thank you for making a bugreport for the issue. We will check this for the next patch release.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th May 2013, 10:01
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 420
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

Hello guys,

please is somebody solving this problem?

It's more serious
First i solved the issue that i removed that part of web templete which allows users setting remote access to db...

But as i found now, when someone change password for pre-3.0.5 user whos databse is not bound to webpage, then even simple password change fails

I'm getting phone calls from clients who changed password for db users every day :||
Reply With Quote
  #4  
Old 17th May 2013, 10:10
radim_h radim_h is offline
Senior Member
 
Join Date: Jan 2007
Location: Prague, Czech
Posts: 420
Thanks: 33
Thanked 24 Times in 19 Posts
Send a message via ICQ to radim_h
Default

simpliest fix will be to tell mysql_clientdb_plugin.inc.php on slave server to get passwords from master server web_database_user instead of slave, as master db is chnaged properly on update, but i don't know ho to do it
Reply With Quote
  #5  
Old 17th May 2013, 12:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
 
Default

The issue has been forwarded to the developer which implemented the new client database plugin.

Did you choose to reconfigure permissions un master database at the time you updated your slave servers?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dovecot v2 with ISPConfig 3 CSsab Installation/Configuration 13 13th September 2012 19:01
My Server Is Sending Spam. How Do I Block This? LordJ Server Operation 1 7th July 2011 19:34
Auth.log question spikes Server Operation 0 12th December 2010 21:24
Samba LDAP, Webmin User password mperreault Server Operation 0 26th August 2008 14:34
log files cruz Technical 3 15th May 2007 14:35


All times are GMT +2. The time now is 08:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.