Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2013, 17:23
r4faga r4faga is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default httpd no start, Error after update Ispconfig. 3.

Hello to all.

Long time to dont ask nothing just because ispconfig works fine.

Last nigth i update my ispconfig 3.0.4 to 3.0.5.2 and all works fine after update. But today i restart httpd and dont start. He show this error:

[Wed May 15 10:02:36 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Wed May 15 10:02:36 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[FAIL]

and httpd dont start it. I read a lot on forums, and till says that this is not an error, but in my case something happened since my apache server dont star and show me the error of virtualhost. I looked at several options but none I've fixed the problem. Can you help? Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 15th May 2013, 17:49
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

Hello,

i'd say you're right in that those two messages on their own are not a problem - its just that apache is listening on a port with no vhosts. There are lots of notes around about resolving that but on its own not a problem.

Are you saying that httpd fails to start altogether? Are you saying you cannot see httpd in a process list or access any of the sites?

You don't say what OS you're running, have a look in the log files see if there's any errors. This could be /var/log/httpd/error.log or similar.

You might try "httpd -D FOREGROUND" see if it spits out any errors there as well?
Reply With Quote
  #3  
Old 15th May 2013, 17:56
r4faga r4faga is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello monkfish, yes i know that this is not error. But after update my ispconfig and restart my apache it dont start it and show me:

root@xxx:/etc/init.d/httpd start

starting httpd: [Wed May 15 10:56:17 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Wed May 15 10:56:17 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[FAIL]

so now i dont have my web sites online, obviously because my apache stop it.

I have centos 6.3, i have it ispconfig 3.0.4 and all works fine but i update to 3.0.5.2 and get this error. Logs dont show any erros about this. And httpd -D FOREGROUND show this
[Wed May 15 10:43:54 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Wed May 15 10:43:54 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

Thank you for you reply.

Last edited by r4faga; 15th May 2013 at 18:09.
Reply With Quote
  #4  
Old 15th May 2013, 18:18
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

Right, so you have got it running in the foreground or does it bail with further error?

If it just sits there after spitting those lines out and doesnt return you to a prompt, I would suggest thats its running.

If its running can you access your sites then? Can you ssh back into the box and do a netstat or a ps and see if httpd shows up.

also try a "apachectl -t" see if your config files check out OK?
maybe a " apachectl -t -D DUMP_VHOSTS" see if your vhost files show up OK.

Once you get your httpd started perhaps go for a resync within the ispconfig interface, the config files will be rewritten

Last edited by monkfish; 15th May 2013 at 18:23. Reason: added
Reply With Quote
  #5  
Old 15th May 2013, 18:22
r4faga r4faga is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

Monkfish thank you for you reply.

Apache is no runing.
Reply With Quote
  #6  
Old 15th May 2013, 18:25
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

If its not running it should put an entry in /var/log/httpd/error.log as to why its unable to start?
Reply With Quote
  #7  
Old 15th May 2013, 18:31
r4faga r4faga is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

error.log show this on final line:

[Wed May 15 11:14:58 2013] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed May 15 11:14:58 2013] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed May 15 11:14:58 2013] [error] Unable to configure RSA server private key
[Wed May 15 11:14:58 2013] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch


I dont know if this error has something to do with the NameVirtualHost error which leaves no start the apache.
Reply With Quote
  #8  
Old 15th May 2013, 19:02
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

Thats suggesting one or more SSL certificates you have applied have an issue which is why apache is prevented from starting.

Have you recently changed/altered ssl certs? Have any expired?

Google is your friend on private key errors.

This user dealt with it previously;
http://www.howtoforge.com/forums/arc...p/t-53543.html

However, I'd try commenting out " SSLEngine on" in any vhost files in /etc/httpd/conf/sites-enabled and see if apache then starts. Suppose it depends if you have https just for ispconfig or you have client sites using it.

If you get it back up you can always reapply the certs through the interface.
Reply With Quote
  #9  
Old 15th May 2013, 19:17
r4faga r4faga is offline
Member
 
Join Date: Jul 2011
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

hunnn monkfish you have rigth, is the FUC?=")/$!"/$ certificates, no i dont changed my certificates, but maybe when I upgrade my ispconfig I think i was create certificates again and that caused this problem, i ll reinstall now SSL certificates again to keep things running well. Thanks a lot, really i did not know what affected the apache certificates. Thanks for your help.
Reply With Quote
  #10  
Old 15th May 2013, 19:21
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
 
Default

Hmm, you don't really say whether it was ispconfig SSL cert or a client cert.

If it was ispconfig look in /usr/local/ispconfig/interface/ssl/ - you may find older certificates in there and could simply swap the files over, then uncomment the entry again, that may work for you.

I was under the impression there was an option during upgrade to recreate SSL certificates and the default is NO?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All files gone after changing quota to 0 spynode General 17 19th January 2012 14:41
update ispconfig 3.0.3.2 to 3.0.3.3 not work 007007 Installation/Configuration 2 30th May 2011 10:41
Monitoring server Ubuntu wiss Installation/Configuration 7 20th November 2010 12:56
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
CPU load locks up box. Apache or MYSQL related. crypted General 61 29th October 2010 22:16


All times are GMT +2. The time now is 06:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.