Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th May 2013, 17:42
patrick3853 patrick3853 is offline
Member
 
Join Date: Dec 2008
Posts: 30
Thanks: 3
Thanked 7 Times in 3 Posts
 
Default ubuntu 13.04 amavis/clamav problems

Hi,

I'm building a virtual users email server on ubuntu 13.04 and mostly following this guide for ubuntu 12.10 (couldn't find one on 13.04).

On page 3 "Install amavisd-new, SpamAssassin, And ClamAV" when I try to restart clamav-daemon:

Code:
/etc/init.d/clamav-daemon restart
I get the following error:

Code:
/etc/init.d/clamav-daemon: line 327: 23637 Killed                  start-stop-daemon --start -o -c $User --exec $DAEMON            [fail]
I've located the problem, which is in /etc/amavis/conf.d/15-content_filter_mode:

Code:
@bypass_spam_checks_maps = (
   \%bypass_spam_checks, \@bypass_spam_checks_acl, \$bypass_spam_checks_re);
I've determined that removing the 3rd element from the @bypass_spam_checks_maps array, which is $bypass_spam_checks_re, fixes the problem. However, from my limited understanding of perl and amavis, I think I want this argument as it appears to ignore spam checking on reply emails (a feature I want). Has anyone else encountered this problem or found a solution other than commenting out the 3rd element? Or could anyone offer some insight as to exactly what effect removing this will have on amavis/clamav?

Thanks
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade to Ubuntu 13.04 Raring Ringtail in less than 20 minutes without problems maknesiumblog Installation/Configuration 0 29th April 2013 16:50
Ubuntu 11.04 x64 + ISPConfig 3 = SASL problems dvazart General 2 5th November 2011 16:16
Problem send/receive Courier+Postfix+Squirrelmail Pirk Installation/Configuration 2 21st May 2010 13:26
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49


All times are GMT +2. The time now is 02:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.