#1  
Old 10th May 2013, 23:52
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default pure-ftpd: can't connect

Its been baffling me for a couple of days. I followed the tutorial
The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3)

and at the bottom of page 4
That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.
But when I tried I got the SSL certificate
but none of the data I put In showed up. I said ok & trusted the cerificate anyway as I know its my server and i'm connecting locally. & then I got

Error: Critical error
Error: Could not connect to server


I used the Encryption: Require explicit FTP over TLS (I'm using FileZilla)

I'm quite new to this, where am I going wrong?

Any help would be truly grateful... Thanks

Last edited by cmsits; 11th May 2013 at 00:44.
Reply With Quote
Sponsored Links
  #2  
Old 12th May 2013, 16:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,231 Times in 4,100 Posts
Default

Seems as if you require tls in your client ithout having ls enabled in the ftp server configuration. Does it work without tls?

Btw. If you are quite new to this, why havent you choosen one of the recommended linux distributions debian or ubuntu? They are much easier to install then centos and even more table on the long run.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
cmsits (16th May 2013)
  #3  
Old 12th May 2013, 16:34
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default

Quote:
Originally Posted by cmsits View Post
Its been baffling me for a couple of days. I followed the tutorial
The Perfect Server - CentOS 6.4 x86_64 (Apache2, Dovecot, ISPConfig 3)

and at the bottom of page 4
That's it. You can now try to connect using your FTP client; however, you should configure your FTP client to use TLS.
But when I tried I got the SSL certificate
but none of the data I put In showed up. I said ok & trusted the cerificate anyway as I know its my server and i'm connecting locally. & then I got

Error: Critical error
Error: Could not connect to server


I used the Encryption: Require explicit FTP over TLS (I'm using FileZilla)

I'm quite new to this, where am I going wrong?

Any help would be truly grateful... Thanks
Did you configure TLS in pure-ftpd AFTER installing ISPConfig? The tutorial is whack and some of the services won't work after you install ISPConfig. The pure-ftpd TLS configuration step cannot be performed in the order that it appears in the tutorial.

Also note that the certificate created in the tutorial will NEVER be used by pure-ftpd. The correct certificate is automatically created for you in the /etc/pki/pure-ftpd directory.

Look at this:

http://www.howtoforge.com/forums/showthread.php?t=61221
Reply With Quote
The Following 2 Users Say Thank You to Hairy For This Useful Post:
cmsits (16th May 2013), crongm (24th May 2013)
  #4  
Old 12th May 2013, 19:17
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

Thanks
I have been studying centos & had a feeling I had not missed anything In the tutorial. Maybe it should be added at the end of the tutorial about TLS being turned off ?
Thanks
Reply With Quote
  #5  
Old 12th May 2013, 19:31
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default

Quote:
Originally Posted by cmsits View Post
Thanks
No problem. Push the Thanks button. lol.

Quote:
Maybe it should be added at the end of the tutorial about TLS being turned off ?
In my opinion, the tutorial should be rewritten to add a step after you install ISPConfig that fixes mailman, dovecot, postfix, and pure-ftpd, as none of these will be working after you follow the tutorial and you install ISPConfig. The tutorial does have the step to fix mailman already after the install.
Reply With Quote
The Following User Says Thank You to Hairy For This Useful Post:
cmsits (16th May 2013)
  #6  
Old 16th May 2013, 18:52
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

Hairy
thanks for the info

what are the fixes for
mailman, dovecot, postfix, and pure-ftpd

big thanks for all your help so far
Reply With Quote
  #7  
Old 17th May 2013, 20:42
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default

Quote:
Originally Posted by cmsits View Post
Hairy
thanks for the info

what are the fixes for
mailman, dovecot, postfix, and pure-ftpd

big thanks for all your help so far
I am working on a tutorial for it. I have written 42 chapters, but I still have 4 more to go. Then, it still needs tested and feedback. I will send you what I have so far to your private messages. Please give me some feedback on it. Once it's complete, I want to submit it to the proper page where I can get a 12 month subscription to the forum in return.
Reply With Quote
The Following 2 Users Say Thank You to Hairy For This Useful Post:
cmsits (19th May 2013), crongm (24th May 2013)
  #8  
Old 19th May 2013, 01:35
cmsits cmsits is offline
Junior Member
 
Join Date: May 2013
Posts: 26
Thanks: 17
Thanked 0 Times in 0 Posts
Default

will be happy to beta test it for you
Reply With Quote
  #9  
Old 24th May 2013, 05:58
crongm crongm is offline
Junior Member
 
Join Date: May 2013
Posts: 1
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

I'd also be happy to beta test or get some instructions. This is the first time I've had to install a server on a VPS, and it's driving me nuts. The bright side is: I've learned quite a few these last couple of weeks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig "backend" completely unfunctional after a restart Xaymar Installation/Configuration 1 22nd August 2011 22:31
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
can't send/receive mail fedora 12 - ispconfig 3 ev0css Installation/Configuration 9 17th May 2010 21:44
ISPConfig 3 Send/Receive mail not working. Acidut General 6 4th April 2010 11:24
Mail not working epicuniversal General 5 13th June 2009 08:24


All times are GMT +2. The time now is 23:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.