Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd May 2013, 22:34
razvandc razvandc is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default My client's website can't acces webmail...some help

Heloo i'm new here and in linux but i do my best to learn .

I've instaled new server with : http://www.howtoforge.com/perfect-se...ot-ispconfig-3

And all service work fine but i cannot acces webmail by client site
exemple : www.client.example.com/webmail

i can acces webmail by server ip address example 88.88.88.158/webmail

But work phpmyadmin www.client.example.com/phpmyadmin
this work ...

Is someone who can help me how to configure webmail or ispconfig to make it work?

Thanks and sorry for my bad english
Reply With Quote
Sponsored Links
  #2  
Old 3rd May 2013, 01:47
Toucan Toucan is offline
Senior Member
 
Join Date: Dec 2009
Posts: 479
Thanks: 78
Thanked 39 Times in 33 Posts
Default

Unless things have changed, this isn't a simple task to achieve. The webmail program runs under a different user than the clients site so permissions would be all different.

I have tried using sym links to achieve this but only partial success.

A simple answer could be up build your client a page with an iframe in it to give the impression of that URL.

Or you could explore url rewrite modules.
Reply With Quote
  #3  
Old 3rd May 2013, 08:29
razvandc razvandc is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok
and another thing when i create a client site without database ex : client.com/webmail works it opens squerremail but when i create a database for respective website squerremail no more work ...
after i create database for respective domain when acces webmail apear something to download and i download and apear this in downloaded file
Quote:
<?php

/**
* index.php
*
* Redirects to the login page.
*
* @copyright 1999-2010 The SquirrelMail Project Team
* @license http://opensource.org/licenses/gpl-license.php GNU Public License
* @version $Id: index.php 13893 2010-01-25 02:47:41Z pdontthink $
* @package squirrelmail
*/

// Are we configured yet?
if( ! file_exists ( 'config/config.php' ) ) {
echo '<html><body><p><strong>ERROR:</strong> Config file ' .
'&quot;<tt>config/config.php</tt>&quot; not found. You need to ' .
'configure SquirrelMail before you can use it.</p></body></html>';
exit;
}

// If we are, go ahead to the login page.
header('Location: src/login.php');

?>
someboy know who ti fix this ?
Reply With Quote
  #4  
Old 3rd May 2013, 08:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,166
Thanks: 829
Thanked 5,412 Times in 4,255 Posts
Default

Quote:
Originally Posted by Toucan View Post
Unless things have changed, this isn't a simple task to achieve. The webmail program runs under a different user than the clients site so permissions would be all different.
This has changed in the meantime. If you follow chapter 20.2 of the perfects etup guide, then squirrelmail runs as apache / www-data user.

http://www.howtoforge.com/perfect-se...ispconfig-3-p6

@razvandc: did you configure squirrelmail as described in chapter 20.2?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Toucan (3rd May 2013)
  #5  
Old 3rd May 2013, 08:41
razvandc razvandc is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes but i will reconfigure maybe i do something wrong ...

i will come back with details thanks !
Reply With Quote
  #6  
Old 4th May 2013, 16:11
razvandc razvandc is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

now i configure like in guide but when i acces website address now go directly to mail

ex when i type my website adress.com now redirect me to squirre mail

how to fix this?
Reply With Quote
  #7  
Old 5th May 2013, 17:15
razvandc razvandc is offline
Junior Member
 
Join Date: May 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

somebody?
when i acces website adress now redirect me directrly to squerremail
please some help
i wil become subscriber but when i will activate my card acount thanks .
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
all created domains from different clients point all towards first created website belleview Installation/Configuration 1 9th February 2013 15:47
Horde Groupware Webmail Edition ByteMe Networking Tips/Tricks/Mods 17 20th December 2012 10:12
webmail in clients web folder uvbnserved Server Operation 4 10th August 2009 08:30
Going to server IP shows clients website edge Installation/Configuration 3 5th August 2009 10:04
website and webmail with same URL hvrossum Installation/Configuration 1 1st January 2008 20:43


All times are GMT +2. The time now is 09:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.