Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th April 2013, 21:46
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default error 500 after upgrade to ubunto 13.04

hello friends.
there is a problem on my server.
i upgrade it to ubunto 13.04 but i cant log in ispconfig. ov got Internal Server Error 500. here is apache2 log
Code:
SoftException in Application.cpp:299: Script "/usr/local/ispconfig/interface/web/index.php" resolving to "/usr/local/ispconfig/interface/web/index.php" not within configured docroot
Premature end of script headers: index.php
mod_php is working. any ideas ?
Reply With Quote
Sponsored Links
  #2  
Old 30th April 2013, 09:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Ensure that you use the correct url to access ispconfig, ispconfig has to be accessed over its port and not with /ispconfig
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th April 2013, 20:47
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default

yes im reaching it with https://www.mysite.com:8080/ but i still have that error 500
Reply With Quote
  #4  
Old 30th April 2013, 23:10
lee.veal lee.veal is offline
Member
 
Join Date: Apr 2013
Posts: 34
Thanks: 6
Thanked 5 Times in 5 Posts
Default

can you post the out put of:

php -v

apache2 -V
Reply With Quote
  #5  
Old 1st May 2013, 12:25
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by lee.veal View Post
can you post the out put of:

php -v

apache2 -V
PHP 5.4.9-4ubuntu2 (cli) (built: Mar 11 2013 16:09:26)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies
with XCache v2.0.0, Copyright (c) 2005-2012, by mOo


Server version: Apache/2.2.22 (Ubuntu)
Server built: Mar 15 2013 14:02:11
Server's Module Magic Number: 20051115:30
Server loaded: APR 1.4.6, APR-Util 1.4.1
Compiled using: APR 1.4.6, APR-Util 1.4.1
Architecture: 64-bit
Server MPM: Prefork
threaded: no
forked: yes (variable process count)
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D DYNAMIC_MODULE_LIMIT=128
-D HTTPD_ROOT="/etc/apache2"
-D SUEXEC_BIN="/usr/lib/apache2/suexec"
-D DEFAULT_PIDLOG="/var/run/apache2.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="/var/run/apache2/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="mime.types"
-D SERVER_CONFIG_FILE="apache2.conf"
Reply With Quote
  #6  
Old 1st May 2013, 16:55
lee.veal lee.veal is offline
Member
 
Join Date: Apr 2013
Posts: 34
Thanks: 6
Thanked 5 Times in 5 Posts
Default

Have you tried disabling xcache ?

In your php.ini file it should look something like this.

;extension = xcache.so

Also check your file permissions, as that can sometimes cause this error
Reply With Quote
  #7  
Old 1st May 2013, 17:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Did you rerun the ispconfig update after updating ubuntu? If not, it might be that the ubuntu update changed any config files. download ispconfig again, run the update.php script which is in the install folder and choose to reconfigure permissions during update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 1st May 2013, 18:12
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
Default

after update.php problem is solved. but now i see that in monitoring site mysql is turned off but its actualy working.
the other strange thing is that
PHP Warning: Illegal string offset 'output' in /usr/local/ispconfig/server/mods-available/monitor_core_module.inc.php on line 707
Reply With Quote
  #9  
Old 1st May 2013, 18:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

ensure that mysql listens also on IP 127.0.0.1.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 1st May 2013, 21:27
DUCKFACE DUCKFACE is offline
Member
 
Join Date: Dec 2008
Location: Bulgaria
Posts: 92
Thanks: 2
Thanked 2 Times in 2 Posts
 
Default

its listentnig on 127.0.0.1 too
as i see IMAP is stopped too.
after upgrade i cant send emails too...
here is error log from mail server

Code:
May  1 20:01:30 server dovecot: auth-worker(15391): mysql(localhost): Connected to database dbispconfig
May  1 20:01:30 server dovecot: imap-login: Login: user=<office@mysite.com>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=15393, secured, session=<3gnCEavbvQB/AAAB>
May  1 20:01:30 server dovecot: imap(office@mysite.com): Disconnected: Logged out in=79 out=710
May  1 20:02:19 server postfix/smtpd[15430]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
May  1 20:02:19 server postfix/smtpd[15430]: connect from localhost[127.0.0.1]
May  1 20:02:19 server postfix/smtpd[15430]: warning: connect to mysql server 127.0.0.1: Can't connect to MySQL server on '127.0.0.1' (111)
May  1 20:02:19 server postfix/smtpd[15430]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
May  1 20:02:19 server postfix/smtpd[15430]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 451 4.3.5 <localhost[127.0.0.1]>: Client host rejected: Server configuration error; from=<office@mysitecom> to=<office@mysite.com> proto=ESMTP helo=<mysite.com>
May  1 20:02:19 server postfix/smtpd[15430]: lost connection after RCPT from localhost[127.0.0.1]
May  1 20:02:19 server postfix/smtpd[15430]: disconnect from localhost[127.0.0.1]
May  1 20:02:21 server postfix/smtpd[15430]: connect from localhost[127.0.0.1]
May  1 20:02:21 server postfix/smtpd[15430]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
May  1 20:02:21 server postfix/smtpd[15430]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 451 4.3.5 <localhost[127.0.0.1]>: Client host rejected: Server configuration error; from=<office@mysite.com> to=<office@mysite.com> proto=ESMTP helo=<mysite.com>
May  1 20:02:21 server postfix/smtpd[15430]: lost connection after RCPT from localhost[127.0.0.1]
May  1 20:02:21 server postfix/smtpd[15430]: disconnect from localhost[127.0.0.1]
Reply With Quote
Reply

Bookmarks

Tags
500, application, error, softexception, upgrade

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade to Ubuntu 13.04 Raring Ringtail in less than 20 minutes without problems maknesiumblog Installation/Configuration 0 29th April 2013 17:50
Upgrade 3.0.3 -> 3.0.4.1 (bug fix release) failed Snowman Installation/Configuration 7 13th December 2011 17:55
site down after apt-get upgrade adnese General 1 20th November 2011 23:31
debian upgrade broken.. apt-get stuck guthrie Installation/Configuration 3 31st March 2009 05:29
Ubunto 8.05 upgrade to 8.10 + ebox planet_fox Server Operation 2 14th November 2008 14:10


All times are GMT +2. The time now is 05:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.