Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th April 2013, 03:13
tahunasky tahunasky is offline
Member
 
Join Date: Jul 2012
Location: Buenos Aires
Posts: 84
Thanks: 1
Thanked 8 Times in 8 Posts
Default ISPConfig 3.0.5.2 not loading - blank page - bug maybe

Hi,

i am getting the following error:

Quote:
[Thu Apr 18 12:49:01 2013] [error] [client 10.0.0.13] PHP Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
[Thu Apr 18 12:49:01 2013] [error] [client 10.0.0.13] PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31
I have just installed the latest version on ubuntu 12.10.
It worked after first install then stopped working after server reboot.

I fixed by changing the permissions on:

/usr/local/ispconfig/interface/lib/config.inc.php

from 600 to 750.

Is this correct ?
Why is this happening ?
Is it a bug ?

thanks
Reply With Quote
Sponsored Links
  #2  
Old 18th April 2013, 08:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,368
Thanks: 833
Thanked 5,477 Times in 4,313 Posts
Default

The correct permissions are 600 and not 750 and what you describe is a configuration issue of your server and not a bug in ispconfig. Php fcgi with suexec is not working correctly on your system and when suexec fails, then you can not access this file enymore. Ensure that suexec is installed and enabled. This happened most likely because you or another admin of that server changed the apache configuration without restarting apache so you recognized the issue after the reboot.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th April 2013, 10:46
tahunasky tahunasky is offline
Member
 
Join Date: Jul 2012
Location: Buenos Aires
Posts: 84
Thanks: 1
Thanked 8 Times in 8 Posts
Default

Hi till..

I did change apache configs, or to be more exact, i copied over sites_available and sites_enabled configs from a 3.0.4.6 server with same version of ubuntu server.

Anyways will do another install and modify the existing files on the new install and let you know if it was me over writing the config files stuffed it up.

thanks for the help/info
Reply With Quote
  #4  
Old 18th April 2013, 11:06
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,368
Thanks: 833
Thanked 5,477 Times in 4,313 Posts
 
Default

Ok, then I guess you copied over the ispconfig.conf and ispconfig.vhost files as well, the ones from3.0.4.6 are incompatible iwth 3.0.5, so if you repkace the 3.0.5. files, the system will fail.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
ISPconfig 3: can't send or receive messages zogthegreat Installation/Configuration 6 22nd May 2010 14:45
Hosting multiple websites and webmail dmwcool Installation/Configuration 8 30th March 2010 03:15
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
Accessing the ISPConfig Web Page nformosa Installation/Configuration 1 9th September 2005 14:13


All times are GMT +2. The time now is 06:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.