Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #61  
Old 15th April 2013, 20:34
Turbanator Turbanator is offline
Senior Member
 
Join Date: Jun 2008
Posts: 218
Thanks: 22
Thanked 16 Times in 16 Posts
Default

I see sogo 2.0.5 is released.
Since I'm running Lenny and it had to be compiled...what do you recommend for performing the "upgrade" from 2.0.4b?

btw, I still haven't touched the outlook/thunderbird stuff but will do so soon. I may need to upgrade to Squeeze though in order for it to work since I think samba 4 is required.
Reply With Quote
The Following User Says Thank You to Turbanator For This Useful Post:
john_tuby8 (22nd July 2013)
Sponsored Links
  #62  
Old 22nd July 2013, 05:22
Turbanator Turbanator is offline
Senior Member
 
Join Date: Jun 2008
Posts: 218
Thanks: 22
Thanked 16 Times in 16 Posts
Default

So I reinstalled from your latest ISP-SOGO.sh w/update 7 (super job by the way) on a multiserver setup
server 1: lenny 64: web, dns, mysql
server 2: squeeze 64: mail (courier)

Problem: I can't send emails outside the server/domain.
I get the error:
Warning
Cannot send message: all recipients are invalid.

I know you had notes on multiserver and I thought I did the correct steps, but maybe not.

Any help would be greatly appreciated.

This is step 1, then I'll move Sogo fully to Squeeze with samba 4 and get openchange working.
Reply With Quote
  #63  
Old 22nd July 2013, 07:02
psykosen psykosen is offline
Junior Member
 
Join Date: Jul 2009
Location: Denmark
Posts: 26
Thanks: 5
Thanked 5 Times in 4 Posts
Default

i can't say what the problem is, but it might be a sql lookup error,
it sounds like a problem with sogo so your best bet is to search the sogo support/faq on the error there is a few others that had that error

if it's a problem with the auto generated config file for sogo let me now, else i can't be of much help.
Reply With Quote
  #64  
Old 22nd July 2013, 07:39
Turbanator Turbanator is offline
Senior Member
 
Join Date: Jun 2008
Posts: 218
Thanks: 22
Thanked 16 Times in 16 Posts
Default

I think I got it.

.GNUstepDefaults was missing

<key>SOGoSMTPAuthenticationType</key>
<string>PLAIN</string>
Reply With Quote
  #65  
Old 22nd July 2013, 08:00
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by Turbanator View Post
I think I got it.
Would it be correct in assuming that you have successfully setup ISPConfig 3 multi-server with SOGo implemented alongside?

If so is that the full setup? Meaning that it has Openchange, Samba4, etc? Or is the cut down version supplying only the Web interface, which in turn is similar to the Roundcube setup?
__________________
Regards,
Steven Swarts
Reply With Quote
  #66  
Old 22nd July 2013, 15:16
Turbanator Turbanator is offline
Senior Member
 
Join Date: Jun 2008
Posts: 218
Thanks: 22
Thanked 16 Times in 16 Posts
Default

Currently only the web interface.

I won't be able to attempt a full openchange/samba4 setup which will include moving the web interface to another server for a few weeks.
Reply With Quote
  #67  
Old 3rd August 2013, 17:43
Turbanator Turbanator is offline
Senior Member
 
Join Date: Jun 2008
Posts: 218
Thanks: 22
Thanked 16 Times in 16 Posts
Default

Update on sogo in multiserver setup.
server1 = ispc, web, dns, mysql
server2 = mail, web, sogo, mysql

Since ispc and users are on server1, in order to get sogo to work on server2, I had to create the sogodb and the views on server1 so that they could grab the ispc users info into the view. Then on server2, instead of creating views, I created a FEDERATED table on the server1_view. This way sogo would look at the table (thinking it was the view), which would actually talk to server1_view which would grab ispc users info.

I don't know if this is the best way, but it's better than duplicating all ispc data on both servers.

I'm still testing any drawbacks and glitches before I attempt openchange.
Reply With Quote
The Following User Says Thank You to Turbanator For This Useful Post:
Konflikted (13th November 2013)
  #68  
Old 14th September 2013, 13:43
forgefan forgefan is offline
Junior Member
 
Join Date: Nov 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi turbanator,
have you had further progress with this?
thanks.
Reply With Quote
  #69  
Old 14th September 2013, 18:41
Turbanator Turbanator is offline
Senior Member
 
Join Date: Jun 2008
Posts: 218
Thanks: 22
Thanked 16 Times in 16 Posts
Default

I have it working as I showed in the previous email. I installed funambol but decided not to go that route with openchange due to complaints of glitches. Instead I went with straight sogo connector for my TB users and webdav collaborator by Bynari bynari.net for Outlook users. It's not the best setup, but it works for me since I don't have may outlook users. Other than me not using it to the fullest, Sogo webmail is awesome and blows roundcube away.

I would love some insight from someone who is using funambol and openchange with this though.
Reply With Quote
  #70  
Old 13th November 2013, 15:43
Konflikted Konflikted is offline
Junior Member
 
Join Date: Nov 2013
Posts: 2
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by Turbanator View Post
Update on sogo in multiserver setup.
server1 = ispc, web, dns, mysql
server2 = mail, web, sogo, mysql

Since ispc and users are on server1, in order to get sogo to work on server2, I had to create the sogodb and the views on server1 so that they could grab the ispc users info into the view. Then on server2, instead of creating views, I created a FEDERATED table on the server1_view. This way sogo would look at the table (thinking it was the view), which would actually talk to server1_view which would grab ispc users info.

I don't know if this is the best way, but it's better than duplicating all ispc data on both servers.

I'm still testing any drawbacks and glitches before I attempt openchange.
Just wanted to ask you did you create just the Views that are created for each mail domain or did you create a view based on each table in the sogodb?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 + SOGo kmh General 1 5th November 2010 14:46
Problems with installing SSL-certifates on ISPConfig3 slaveservers Hans General 4 5th October 2010 12:22
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
ISPConfig3 FTP problem karazy-k Server Operation 6 3rd September 2009 16:03
Questions about ISPConfig3 vs. ISPConfig2 atjensen11 General 1 14th March 2009 23:59


All times are GMT +2. The time now is 22:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.