Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th April 2013, 18:37
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default Updated to 3.5.2 from 3.4.6 errors starting panel

Just upgraded to 3.5.2
OS: centos 5.9
php:5.3.23
apache:2.2.23

Just can't get the panel up.
I get a 503 error

error_log:
[Wed Apr 10 09:26:23 2013] [error] (13)Permission denied: mod_fcgid: couldn't bind unix domain socket /etc/httpd/run/mod_fcgid/15487.447
[Wed Apr 10 09:26:23 2013] [warn] (13)Permission denied: mod_fcgid: spawn process /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter error
[Wed Apr 10 09:26:23 2013] [warn] [client 172.218.2.10] mod_fcgid: can't apply process slot for /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter

Any thoughts on the subject.
Thanks
korbynn
Reply With Quote
Sponsored Links
  #2  
Old 12th April 2013, 03:12
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Is there anyone out there that can point me in the right direction?
It appears that I have a permissions problem. What user should own the ispconfig data?
Reply With Quote
  #3  
Old 12th April 2013, 09:37
compugraphix compugraphix is offline
Member
 
Join Date: Jul 2010
Posts: 39
Thanks: 6
Thanked 1 Time in 1 Post
Default

look here : http://linuxadmintips4u.blogspot.nl/...-modfcgid.html

looks like a permission error maybe this link can help you.

maybe if you do a vi on /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter
it gives you the location of the file with not enough permission to be run

mine gives:

#!/bin/sh
PHPRC=/etc/php5/cgi/
export PHPRC
export PHP_FCGI_MAX_REQUESTS=5000
export PHP_FCGI_CHILDREN=1
exec /usr/bin/php-cgi -d magic_quotes_gpc=off -d session.save_path=/usr/local/ispconfig/server/temp


------------------------------------------------
/etc/php5/cgi/
php.ini (0644 root:root)
in the dir there is also a ln -s link to conf.d

/usr/bin/php-cgi (0755 root:root)

Hope this helps
Reply With Quote
  #4  
Old 15th April 2013, 02:06
korbynn korbynn is offline
Member
 
Join Date: May 2009
Posts: 81
Thanks: 2
Thanked 4 Times in 4 Posts
Default

Found a fix.
Paths needed to be fixed.

in /etc/httpd/conf.d/fcgid.conf

from:

Code:
...
# Use FastCGI to process .fcg .fcgi & .fpl scripts
# Don't do this if mod_fastcgi is present, as it will try to do the same thing
<IfModule !mod_fastcgi.c>
    AddHandler fcgid-script fcg fcgi fpl
</IfModule>

# Sane place to put sockets and shared memory file
SocketPath run/mod_fcgid
SharememPath run/mod_fcgid/fcgid_shm
to:

Code:
...
# Use FastCGI to process .fcg .fcgi & .fpl scripts
# Don't do this if mod_fastcgi is present, as it will try to do the same thing
#<IfModule !mod_fastcgi.c>
    AddHandler fcgid-script fcg fcgi fpl
#</IfModule>

# Sane place to put sockets and shared memory file
SocketPath /var/run/mod_fcgid
SharememPath /var/run/mod_fcgid/fcgid_shm

FcgidIPCDir /var/run/mod_fcgid
FcgidProcessTableFile /var/run/mod_fcgid/fcgid_shm
Reply With Quote
  #5  
Old 7th May 2013, 01:43
ejg ejg is offline
Junior Member
 
Join Date: Feb 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default same problem, but no fcgid.conf

I have the same problem : error 503 when trying to access the panel.

same errors in the error_log, but I don't have an fcgid.conf file in the conf.d folder.

/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter does not show any permission errors

websites are working fine, but the panel is not accessible,

any thoughts?
Reply With Quote
  #6  
Old 8th May 2013, 17:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th May 2013, 17:56
ejg ejg is offline
Junior Member
 
Join Date: Feb 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I am running CentOS 5.9 and upgraded to 3.0.5.2
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High on Lenny - Lvm Mount Problem Serverman Technical 1 23rd June 2009 16:26
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
dns server error Hellbound General 7 2nd August 2007 09:18
Bind Starting Errors dabro51 Installation/Configuration 2 28th March 2007 22:46
After install error(s) by starting ISPconfig BvO Installation/Configuration 4 14th January 2007 15:17


All times are GMT +2. The time now is 10:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.