Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st April 2013, 21:56
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 187
Thanks: 39
Thanked 4 Times in 4 Posts
Smile

Hi Darin,

It shouldn't be a problem because I'm only running primary nameserver like in this tutorial: http://www.howtoforge.com/ispconfig_...domain_schlund - and like in this tutorial I'm using a domain hosting service as secondary nameserver. Actually my nameservers were the only thing working proberly. Testing on the IP that is. The nameserver answers just fine. Its the other things: mails incomming (pop3/IMAP) and websites that teased me.
Now I am almost through with the reinstallation using the domain registrated for use as nameserver/webserver etc.
More to come.. Its a little difficult some times, this using a forum, a lot gets lost in translation. By the way, I'm from denmark, copenhagen area.. Which country are you from? I'm just a little nosy you know, its fun to know where the people you are talking to are sitting on the globe

Returning after reinstallation completed - and the nameserver records re-done

PS! This was one of my issues before "killing" the server - and doing a reinstall
These fail messages was prompted after an update:

* Stopping Courier IMAP-SSL server imapd-ssl
...done.
* Starting Courier IMAP-SSL server imapd-ssl
...done.
* Stopping Courier POP3 server...
...done.
* Starting Courier POP3 server...
...done.
* Stopping Courier POP3-SSL server...
...done.
* Starting Courier POP3-SSL server...
...done.
* Restarting web server apache2
[Fri Mar 29 21:24:28 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Mar 29 21:24:28 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[Fri Mar 29 21:24:29 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Mar 29 21:24:29 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
... waiting ...done.
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -8 UTF-8 -H -O clf:/var/log/pure-ftpd/transfer.log -A -D -b -E -B
Update finished.



Kind Regards,
Dan
Reply With Quote
Sponsored Links
  #12  
Old 1st April 2013, 23:48
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 187
Thanks: 39
Thanked 4 Times in 4 Posts
Question Getting close - but, do-release-upgrade before or after ISP inst.???

Hi Darin,

I'm getting closer, but...
Have just posted ths: http://www.howtoforge.com/forums/sho...156#post295156 regarding this reinstallation. I'm not sure about what to do with the "do-release-upgrade"!?! Is it more right to do this now or after the installation of ISPConfig3 CP. Will it make any difference.
Well, I lost some courage durin these reinstallations. Maybe because of the "long nights" without any sleep or maybe just because I would like to make it the right way

And, I am not sure about mailman either, because, I'm not quite sure if I will need it or exactly what it does - but due to the tutorial it is recommended that you install it before the ISPConfig3 CP!

Kind Regards,
Dan
Reply With Quote
  #13  
Old 2nd April 2013, 01:13
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

Dan,

I'm from the US, though, i have Danish heritage in my family.

Quote:
* Stopping Courier IMAP-SSL server imapd-ssl
...done.
* Starting Courier IMAP-SSL server imapd-ssl
...done.
* Stopping Courier POP3 server...
...done.
* Starting Courier POP3 server...
...done.
* Stopping Courier POP3-SSL server...
...done.
* Starting Courier POP3-SSL server...
...done.
* Restarting web server apache2
[Fri Mar 29 21:24:28 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Mar 29 21:24:28 2013] [warn] NameVirtualHost *:80 has no VirtualHosts
[Fri Mar 29 21:24:29 2013] [warn] NameVirtualHost *:443 has no VirtualHosts
[Fri Mar 29 21:24:29 2013] [warn] NameVirtualHost *:80 has no VirtualHosts

... waiting ...done.
Restarting ftp server: Running: /usr/sbin/pure-ftpd-mysql-virtualchroot -l mysql:/etc/pure-ftpd/db/mysql.conf -l pam -u 1000 -8 UTF-8 -H -O clf:/var/log/pure-ftpd/transfer.log -A -D -b -E -B
Update finished.
There is nothing of a huge deal in any of what you posted above. You obviously installed Courier. The services are just being configured.

As for the NameVirtualHost issue... This just started appearing on my servers on the install of ISPConfig 3.0.5.2. I've had an open question about it, but nobody replying to it.

Yes, I'm sure you're a bit loopy from no sleep, but feel free to ask explicit questions if you have them.

Darin
Reply With Quote
The Following User Says Thank You to darinpeterson For This Useful Post:
danhansen@denmark (5th April 2013)
  #14  
Old 4th April 2013, 23:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

Quote:
Originally Posted by darinpeterson View Post
As for the NameVirtualHost issue... This just started appearing on my servers on the install of ISPConfig 3.0.5.2. I've had an open question about it, but nobody replying to it.
Just ignore these warnings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
danhansen@denmark (5th April 2013)
  #15  
Old 5th April 2013, 02:26
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 187
Thanks: 39
Thanked 4 Times in 4 Posts
Exclamation Will do just that ;)

Hi Darin and Falko,

I ill do just that
Thanks, both of you!

I am getting pretty close, but still some beginners-errors I think it may be. But not lazy mistakes - have been reading more than 200 pages of the manual Please, will you take a look at this thread's last post: http://www.howtoforge.com/forums/showthread.php?t=61257

Looking forward to hear from you..

Kind Regards,
Dan
Reply With Quote
  #16  
Old 9th April 2013, 03:01
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Arrow A better recommendation.

Quote:
Originally Posted by darinpeterson View Post
Hi Dan,

Please correct me if I'm wrong, but it sounds like you want to use this single server to host websites AND resolve domains. The problem that your service provider has is that they wan the name server separate from your hosting domain. The only way I know how to do this is to have two servers. One could be virtual, but you're going to need another IP. That means you would have to install something like OpenVZ on your system. If I am wrong, please provide more information.

As far as mail services, I don't know enough about them to recommend one over the other. I run Courier. I'm sure there are plenty of smart people reading this post who would be better qualified to reply to this question.

Regards,
Darin
Hi Dan,

I now have more experience with mail servers. Having run Courier for a long while, I recently spent some time researching recommendations and reviews. After having done that, I have migrated to Dovecot. It has better memory management and it's easier to configure...

Not sure that helps at this point, but I wanted to follow up with this information...

Regards,
Darin
Reply With Quote
  #17  
Old 9th April 2013, 10:25
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 187
Thanks: 39
Thanked 4 Times in 4 Posts
Exclamation Dovecot User To Be :)

Hi Darin,

Thanks!
But of course it helps.. This I will put in my ToDo-Box because I have been hearing about this "Dovecot/Courier" fight for a long time. I too will migrate to "Dovecot" when I am ready

PS! Did you se my message regarding the server now is up and running? Havent read all my new posts yet so I don't know if you have responded to any of them

Kind Regards,
Dan
Reply With Quote
  #18  
Old 9th April 2013, 15:56
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
 
Default

Sure you're welcome Dan...

I look at the Linux forums daily, but have not seen your other posts. Feel free to send me a private message with links, if you want me to take a look.

Best regards,
Darin
Reply With Quote
The Following User Says Thank You to darinpeterson For This Useful Post:
danhansen@denmark (9th April 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help cant access anything locally or from ip jimmie Installation/Configuration 14 5th March 2013 07:58
500 internal error after upgrade abintipl Installation/Configuration 9 18th July 2012 12:51
Intel 82815 Video Card & Ubuntu 8.10 harvey527 Kernel Questions 8 5th November 2010 14:51
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 02:30


All times are GMT +2. The time now is 21:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.