Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th April 2013, 17:35
gleidsonlm gleidsonlm is offline
Junior Member
 
Join Date: May 2006
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default Cannot flush mail queue - mail system is down

Postfix isn't sending messages, I got this error trying to queue:

Code:
# postqueue -vf
postqueue: name_mask: all
postqueue: inet_addr_local: configured 2 IPv4 addresses
postqueue: inet_addr_local: configured 2 IPv6 addresses
postqueue: fifo_trigger: open public/qmgr: cannot open file: No such device or address
postqueue: fatal: Cannot flush mail queue - mail system is down
I found two files with qmgr in name, but they look ok about user and file permissions.

Code:
# find / -iname qmgr -exec ls -la {} \;
-rwxr-xr-x 1 postfix postfix 67520 2011-10-07 01:20 /usr/lib/postfix/qmgr
prwxr-xr-x 1 postfix postdrop 0 2013-04-04 19:30 /var/spool/postfix/public/qmgr
postfix check returns all good

Code:
# postfix -v check
postfix: name_mask: all
postfix: inet_addr_local: configured 2 IPv4 addresses
postfix: inet_addr_local: configured 2 IPv6 addresses
Enviroment:
Ubuntu 11.10 oneiric
Postfix 2.8.5-2~build1
Installed with ISPConfig3 using Howtoforge server perfect setup.

Mail Error Log:

Code:
Apr  8 12:28:11 ip-10-252-142-252 postfix/smtpd[11567]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Apr  8 12:30:07 ip-10-252-142-252 postfix/pickup[11740]: fatal: connect #11 to subsystem public/cleanup: Connection refused
Apr  8 12:30:52 ip-10-252-142-252 postfix/smtpd[11806]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Apr  8 15:30:53 ip-10-252-142-252 postfix/postqueue[11976]: fatal: Cannot flush mail queue - mail system is down
Apr  8 12:32:48 ip-10-252-142-252 postfix/pickup[12030]: fatal: connect #11 to subsystem public/cleanup: Connection refused
Apr  8 12:33:33 ip-10-252-142-252 postfix/smtpd[12057]: fatal: connect #11 to subsystem private/proxymap: Connection refused
Apr  8 15:33:37 ip-10-252-142-252 postfix/postqueue[12392]: fatal: Cannot flush mail queue - mail system is down
Apr  8 12:35:29 ip-10-252-142-252 postfix/pickup[12396]: fatal: connect #11 to subsystem public/cleanup: Connection refused
Apr  8 12:36:14 ip-10-252-142-252 postfix/smtpd[12472]: fatal: connect #11 to subsystem private/proxymap: Connection refused
all services running, but postfix:

Code:
# service amavis status
 * amavisd is running
# service clamav-daemon status
 * clamd is running
# service postfix status
 * postfix is not running
What should I looking for fix this?

Last edited by gleidsonlm; 8th April 2013 at 17:41. Reason: including logs and daemons runing
Reply With Quote
Sponsored Links
  #2  
Old 8th April 2013, 20:05
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

I'm not quite sure where to start with this one, so do you get any errors when you do:

Code:
/etc/init.d/postfix start
Reply With Quote
  #3  
Old 8th April 2013, 21:06
gleidsonlm gleidsonlm is offline
Junior Member
 
Join Date: May 2006
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks for awsering, but any erros showed:

Code:
# /etc/init.d/postfix start
 * Starting Postfix Mail Transport Agent postfix                                                                                                                                                        [ OK ]
But when I seek for status:

Code:
# /etc/init.d/postfix status
 * postfix is not running
End again, same error...

Code:
postqueue: name_mask: all
postqueue: inet_addr_local: configured 2 IPv4 addresses
postqueue: inet_addr_local: configured 2 IPv6 addresses
postqueue: fifo_trigger: open public/qmgr: cannot open file: No such device or address
postqueue: fatal: Cannot flush mail queue - mail system is down
Reply With Quote
  #4  
Old 9th April 2013, 02:08
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 153
Thanks: 35
Thanked 13 Times in 13 Posts
Default

I'm sorry. I don't know. Hopefully someone else with more background with postfix will see this, and help.
Reply With Quote
The Following User Says Thank You to darinpeterson For This Useful Post:
gleidsonlm (9th April 2013)
  #5  
Old 9th April 2013, 12:54
gleidsonlm gleidsonlm is offline
Junior Member
 
Join Date: May 2006
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

I tried to "purge" all packages related and reinstall, but any effect.

I just finish to look this post quoted at perfect server howto, but also any effect.
http://www.howtoforge.com/forums/sho...1&postcount=25

Right now, I'm kind of scary about this... the queue sums up 10k messages and nothing I do can send them. If someone has a hint about what should I looking after, please tell me.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 10:56
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
ISPconfig 3 some users cannot send email to outside Rockblade Installation/Configuration 7 29th April 2010 01:40
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57


All times are GMT +2. The time now is 13:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.