Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 2nd April 2013, 05:21
alleks alleks is offline
Senior Member
 
Join Date: Nov 2010
Posts: 157
Thanks: 9
Thanked 9 Times in 9 Posts
Default Optmizing Apache and php-cgi for CPU Usage

I'm having a huge problem with a server where I run 2 wp blogs.

The problem is that sometimes my cpu goes sky rocking high, and just don't know what else todo. I've configured APC, huge difference, reduced Timeouts on Apache and MySQL tuning, but now I have to find a method to optimize the CPU usage.

And some times this is the output I get in the error log files for the sites:
Code:
 mod_fcgid: can't apply process slot for /var/www/php-fcg
i-scripts/web2/.php-fcgi-starter
and this in my apache2/error.log file

Code:
[error] mod_fcgid: process /var/www/php-fcgi-scripts/web2/.php-fcgi-starter(31462) exit(communication error), get unexpected signal 7
So, what do you recommend me to try and lower my cpu usage and keep serving content to users. I have a VPS from 1and1 (I kinda repent know for the decision) with 1cpu and 2gb ram, and planning to get another cpu... but I don't like the way they changed the prices.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ispconfig 3 staff007 Installation/Configuration 4 10th October 2011 21:17
coexistence of php4 and php5 on ISPC3 AceLine Tips/Tricks/Mods 5 5th November 2010 14:56
Error when install ISPConfig 2 with components built from source X-admin Installation/Configuration 5 30th April 2010 13:22
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22


All times are GMT +2. The time now is 14:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.