Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st March 2013, 17:07
stoney stoney is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Cant send emails from outside network "reject: RCPT from"

Hi
I installed the The Perfect Server - Ubuntu 12.10 and am getting these errors when trying to use outlook an cannot sent emails.

I have also installed Gallery3 through ISPconfig and im not sure that the email was working before i installed it.


/var/log/mail.log

Quote:
Mar 31 15:41:04 adl2 postfix/smtpd[7987]: connect from ***.bb.sky.com[****.****.****.****]
Mar 31 15:41:04 adl2 postfix/smtpd[7987]: NOQUEUE: reject: RCPT from ***.bb.sky.com[****.****.****.****]: 554 5.7.1 <TEST@gmail.com>: Relay access denied; from=<admin@mydomain.co.uk> to=<TEST@gmail.com> proto=SMTP helo=<MYPC>
Mar 31 15:41:05 adl2 postfix/smtpd[7987]: disconnect from ***.bb.sky.com[****.****.****.****]
Mar 31 15:41:05 adl2 dovecot: auth-worker(8025): mysql(localhost): Connected to database dbispconfig
Mar 31 15:41:06 adl2 dovecot: imap-login: Login: user=<admin@mydomain.co.uk>, method=PLAIN, rip=****.****.****.****, lip=192.168.0. 99, mpid=8027, TLS, session=<fxGHfjnZgQBeBFKd>
Mar 31 15:41:13 adl2 dovecot: imap(admin@mydomain.co.uk): Disconnected: Logged out in=3324 out=206515


/ect/postfig/main.cf

Quote:
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no
append_dot_mydomain = no
readme_directory = /usr/share/doc/postfix
# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

myhostname = mydomain.co.uk
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
myorigin = /etc/mailname
mydestination = localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8 [::1]/128
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
inet_protocols = all
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_tls_security_level = may
transport_maps = hash:/var/lib/mailman/data/transport-mailman, proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_client_message_rate_limit = 100
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
virtual_transport = dovecot
header_checks = regexp:/etc/postfix/header_checks
mime_header_checks = regexp:/etc/postfix/mime_header_checks
nested_header_checks = regexp:/etc/postfix/nested_header_checks
body_checks = regexp:/etc/postfix/body_checks
owner_request_special = no
dovecot_destination_recipient_limit = 1
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
message_size_limit = 0

Ive looked through loads of sites but cant find a fix.
Any suggestions would be greatly appreciated.

Thanks
John

Last edited by stoney; 1st April 2013 at 00:06.
Reply With Quote
Sponsored Links
  #2  
Old 1st April 2013, 21:37
stoney stoney is offline
Junior Member
 
Join Date: Mar 2013
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

SOLVED !!!!

I needed to tick the "My outgoing server (SMTP) requires authentication) in Outgoing server settings in outlook.

Should have noticed this before.

Last edited by stoney; 1st April 2013 at 22:42.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix queue problem? murunix Server Operation 7 2nd May 2011 01:55
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 19:59
Unable to connect to Mysql mbascombe Installation/Configuration 12 10th January 2010 22:46
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30


All times are GMT +2. The time now is 14:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.