Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th March 2013, 00:31
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
Default Updating or Installing ISPConfig 3 Turns Pure-FTPD TLS Back Off

Whenever I run update.php or install.php from ispconfig3_install/install/, The TLS option in Pure-FTPD is turned back off.

The tutorial here http://www.howtoforge.com/perfect-se...ot-ispconfig-3 tells you to turn on TLS in step 16, Then, in step 24, when you install ISPConfig, it will turn TLS back off. You must then go back and uncomment the TLS option in the file /etc/pure-ftpd/pure-ftpd.conf and restart Pure-FTPD. The tutorial does not mention that you will no longer have TLS enabled after installing ISPConfig. Shouldn't the Pure-FTPD TLS option be configured AFTER installing ISPConfig, if ISPConfig is just going to turn it back off?

Is this behavior in ISPConfig a bug?

Tested On:
ISPConfig 3.0.5.2 - CentOS 6.4
ISPConfig 3.0.4.6 - CentOS 6.3
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2013, 13:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

ISPConfig is just not aware of the tls option so you have to reenable it on centos aftre updates. On Debian and Ubuntu there are no such problems as they use a modular pureftpd configuration.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following 2 Users Say Thank You to till For This Useful Post:
crongm (24th May 2013), Hairy (4th April 2013)
  #3  
Old 4th April 2013, 09:27
Hairy Hairy is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Location: USA
Posts: 57
Thanks: 6
Thanked 27 Times in 16 Posts
 
Default

Quote:
Originally Posted by till View Post
ISPConfig is just not aware of the tls option so you have to reenable it on centos aftre updates. On Debian and Ubuntu there are no such problems as they use a modular pureftpd configuration.
Thank you very much for confirming that configuring TLS in step 14 is pointless, as it will just get overwritten, and that TLS configuration for Pure-FTPD should be done AFTER step 24 in the perfect server setup guide, instead of step 14.
Reply With Quote
The Following User Says Thank You to Hairy For This Useful Post:
crongm (24th May 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix can't received email from exterior astra2000 Server Operation 5 18th October 2009 00:26
Error installing ISPConfig on debian omniware Installation/Configuration 3 10th September 2008 16:36
Problems with installation on openSUSE 10.2 douglaslopezt Installation/Configuration 3 24th August 2007 23:04
Installing ISPConfig on a pre-installed x86_64 FC6 w/webmin domino Installation/Configuration 2 13th February 2007 12:21
Installing ISPConfig ssl installation certificate to a site? lyndros Installation/Configuration 6 20th March 2006 04:54


All times are GMT +2. The time now is 21:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.