Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th March 2013, 09:14
horrorshow horrorshow is offline
Junior Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig 3.0.4.6 - Mail() does not route to remote MX when to domain on local server

Originally posted this in the wrong forum. I think this may be an ISPConfig 3.0.4.6 bug but wanted to make sure, or see if there's a simple way to resolve this.

Running Postfix/courier

Linux 2.6.32-042stab055.16 #1 SMP Fri Jun 8 19:22:28 MSD

CentOS release 6.3 (Final)

Added an entry in Advanced Mail Routing for the domain to googles SMTP ip address.

When I try to send an email using PHP's mail() function to any other email address, it works fine. When sending to an email address of a site on the local server, it tries to route it to localhost, where it doesn't find any email account because the mail account is on google apps remote mx:

Mar 28 15:01:31 vds1 postfix/smtpd[582]: NOQUEUE: reject: RCPT from localhost[127.0.0.1]: 550 5.1.1 <work@xxxxxxxxxxx.com>: Recipient address rejected: User unknown in relay recipient table; from=<webmaster@xxxxxxxxxxx.com> to=<work@xxxxxxxxxxx.com> proto=ESMTP helo=<xxxxxxxxxxx.com>

Mar 28 15:01:31 vds1 sendmail[652]: r2SC1UVX000652: to=work@xxxxxxxxxxx.com, ctladdr=webmaster@xxxxxxxxxxx.com (48/48), delay=00:00:01, xdelay=00:00:00, mailer=relay, pri=30079, relay=[127.0.0.1] [127.0.0.1], dsn=5.1.1, stat=User unknown

The domain xxxxxxxxxxx.com is added as a site, but not a mail domain. Do I have this configured wrong, or is something else wrong? This is causing a form to not properly deliver emails.

Thanks!

Last edited by horrorshow; 29th March 2013 at 09:29. Reason: clarifying use of advanced mail routing
Reply With Quote
Sponsored Links
  #2  
Old 29th March 2013, 23:16
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 38
Thanked 90 Times in 68 Posts
Default

Quote:
User unknown in relay recipient table
You must define what will be relayed to google under Email->Relay Recipents. Just add the full email address there.

Cheers
Reply With Quote
  #3  
Old 29th March 2013, 23:44
horrorshow horrorshow is offline
Junior Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is it possible to add the entire domain or wildcard?
Reply With Quote
  #4  
Old 29th March 2013, 23:48
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 38
Thanked 90 Times in 68 Posts
Default

Yes with @domain.com but is very dangerous, you can become a backscatter source. Anyone can send you an email to a non existing address and the remote server will be send a bounce.
Reply With Quote
The Following User Says Thank You to pititis For This Useful Post:
sistemas (15th April 2013)
  #5  
Old 30th March 2013, 21:54
horrorshow horrorshow is offline
Junior Member
 
Join Date: Mar 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I am curious about this. Since the MX is going to google apps, all emails should go there anyway, so how would this generate backscatter involving the local server settings? Wouldn't this only be a potential issue if the local server was compromised or the mail() script was easily abused?
Reply With Quote
Reply

Bookmarks

Tags
advanced mail routing, googleapps, ispconfig, postfix

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix DoS Spam attack arraken Installation/Configuration 29 4th April 2013 14:08
help cant access anything locally or from ip jimmie Installation/Configuration 14 5th March 2013 07:58
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
dovecot: lda: Fatal: Unknown user dpicella Installation/Configuration 1 22nd August 2010 02:59
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33


All times are GMT +2. The time now is 11:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.