Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 13th March 2013, 00:27
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

I'm still having problems. I rechecked my settings per the ispconfig setup.

Every time I try to restart NGINX I get:
Code:
nginx: [emerg] unknown "https" variable
nginx: configuration file /etc/nginx/nginx.conf test failed
I am specifying that I am using https in my nginx.conf


[code]
[root@node1 cgi-bin]# vi /etc/nginx/nginx.conf

http {
## Detect when HTTPS is used
map $scheme $fastcgi_https {
default off;
https on;
}
include /etc/nginx/mime.types;
default_type application/octet-stream;

log_format main '$remote_addr - $remote_user [$time_local] "$request" '
'$status $body_bytes_sent "$http_referer" '
'"$http_user_agent" "$http_x_forwarded_for"';

access_log /var/log/nginx/access.log main;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 65;

#gzip on;


wtf am I doing wrong? Why do I have to edit apps.vhost. to and comment out
https variables to get my sites backup?

HALP Falko and Timme

Last edited by Rockdrala; 13th March 2013 at 00:32.
Reply With Quote
Sponsored Links
  #12  
Old 14th March 2013, 22:18
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default Reinstalled Still Error

Im still getting a Starting nginx: nginx: [emerg] unknown "https" variable
Fresh install following per http://www.howtoforge.com/perfect-se...ispconfig-3-p7


The
Code:
http {
        ## Detect when HTTPS is used
        map $scheme $fastcgi_https {
          default off;
          https on;
        }
is added as instructed in the guide.

The nginx version is 1.0.15 and ispconfig is 3.0.5.1

Code:
[root@node1 install]# cat /var/log/nginx/error.log

2013/03/14 13:49:37 [emerg] 22414#0: unknown "https" variable
2013/03/14 13:49:40 [emerg] 22478#0: unknown "https" variable
2013/03/14 13:54:32 [emerg] 22664#0: unknown "https" variable
2013/03/14 13:54:36 [emerg] 22674#0: unknown "https" variable
2013/03/14 13:54:37 [emerg] 22684#0: unknown "https" variable
2013/03/14 14:12:50 [emerg] 23329#0: unknown "https" variable
2013/03/14 14:23:44 [emerg] 23698#0: unknown "https" variable
2013/03/14 14:52:44 [emerg] 24649#0: unknown "https" variable
2013/03/14 15:01:32 [emerg] 25002#0: unknown "https" variable

Last edited by Rockdrala; 14th March 2013 at 22:23. Reason: added error log.
Reply With Quote
  #13  
Old 14th March 2013, 22:52
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

http://serverfault.com/questions/484...https-variable

This forum says to upgrade to 1.2.7 but the os wont let it after adding the repository it requested.

Code:
[root@node1 ~]# vi /etc/yum.repos.d/nginx.repo
[root@node1 ~]# yum upgrade nginx
Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: mirror.sanctuaryhost.com
 * epel: mirror.steadfast.net
 * extras: mirrors.gigenet.com
 * rpmforge: mirror.teklinks.com
 * updates: mirror.steadfast.net
http://nginx.org/packages/centos/6.4/x86_64/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: nginx. Please verify its path and try again
[root@node1 ~]# vi /etc/yum.repos.d/nginx.repo
[root@node1 ~]# yum upgrade nginx
Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: mirror.sanctuaryhost.com
 * epel: mirror.steadfast.net
 * extras: mirrors.gigenet.com
 * rpmforge: mirror.teklinks.com
 * updates: mirror.steadfast.net
nginx                                                    | 1.3 kB     00:00
nginx/primary                                            | 5.0 kB     00:00
nginx                                                                     35/35
1370 packages excluded due to repository priority protections
Setting up Upgrade Process
No Packages marked for Update
[root@node1 ~]# yum install nginx
Loaded plugins: fastestmirror, priorities, security
Loading mirror speeds from cached hostfile
 * base: mirror.sanctuaryhost.com
 * epel: mirror.steadfast.net
 * extras: mirrors.gigenet.com
 * rpmforge: mirror.teklinks.com
 * updates: mirror.steadfast.net
1370 packages excluded due to repository priority protections
Setting up Install Process
Package nginx-1.0.15-3.el6.x86_64 already installed and latest version
Nothing to do

I cant figure it out.
Reply With Quote
  #14  
Old 14th March 2013, 23:04
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

After enabling the Remi repository and setting the nginx repository to priority 1 I finally got upgraded to 1.2.7.


Code:
nginx                                                    | 1.3 kB     00:00
remi                                                     | 2.9 kB     00:00
remi/primary_db                                          | 494 kB     00:01
1421 packages excluded due to repository priority protections
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package nginx.x86_64 0:1.0.15-3.el6 will be updated
---> Package nginx.x86_64 0:1.2.7-1.el6.ngx will be an update
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package        Arch            Version                    Repository      Size
================================================================================
Updating:
 nginx          x86_64          1.2.7-1.el6.ngx            nginx          364 k

Transaction Summary
================================================================================
Upgrade       1 Package(s)

Total download size: 364 k
Is this ok [y/N]: y
Downloading Packages:
nginx-1.2.7-1.el6.ngx.x86_64.rpm                         | 364 kB     00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : nginx-1.2.7-1.el6.ngx.x86_64                                 1/2
warning: /etc/nginx/fastcgi_params created as /etc/nginx/fastcgi_params.rpmnew
warning: /etc/nginx/nginx.conf created as /etc/nginx/nginx.conf.rpmnew
  Cleanup    : nginx-1.0.15-3.el6.x86_64                                    2/2
  Verifying  : nginx-1.2.7-1.el6.ngx.x86_64                                 1/2
  Verifying  : nginx-1.0.15-3.el6.x86_64                                    2/2

Updated:
  nginx.x86_64 0:1.2.7-1.el6.ngx

Now to figure out what ...
Code:
 /etc/nginx/fastcgi_params.rpmnew
warning: /etc/nginx/nginx.conf created as /etc/nginx/nginx.conf.rpmnew
broke.
Reply With Quote
  #15  
Old 14th March 2013, 23:23
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

Found the problem. Falko your guide causes the install of nginx 1.0.15 which is too old to use with parameters of vhost generated by by your new ispconfig versions.

If you update the repository in your guide to install 1.2.7 instead it works fine.

All sites are back up. No errors. "WHEW"
Reply With Quote
  #16  
Old 15th March 2013, 14:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Ok, I guess this happened because of the line

Code:
fastcgi_param   HTTPS                   $https;
in the apps vhost.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 28th March 2013, 15:08
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

You are correct sir =)
Reply With Quote
  #18  
Old 19th November 2013, 17:36
PermaNoob PermaNoob is offline
Senior Member
 
Join Date: Jan 2007
Posts: 194
Thanks: 12
Thanked 5 Times in 5 Posts
 
Default

I have the same problem, but his fix:
Quote:
solved by remove

from
/etc/nginx/sites-available/apps.vhost
/etc/nginx/sites-enabled/000-apps.vhost

the lines

# fastcgi_param HTTPS $server_https;
did nothing. Is there another fix?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails: fine > recive: bad Moundy General 1 20th June 2012 00:40
Newly Installed ISPConfig3 on Ubuntu 8.04 : login redirect fail ? cripperz Installation/Configuration 5 22nd March 2009 13:15
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 14:06
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 14:29
php script injections Grizzly General 21 18th July 2006 09:55


All times are GMT +2. The time now is 10:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.