Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 27th March 2013, 15:15
j0nte j0nte is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix does not notify on error

First off, postfix works fine if I use an adress that exists.
But if I send a email to a user/adress that does not exist I would want them to get a reply with that.
This is my mail.log
Code:
Mar 27 14:56:40 control postfix/smtpd[3419]: connect from mail-qe0-f49.google.com[209.85.128.49]
Mar 27 14:56:40 control postfix/smtpd[3419]: Anonymous TLS connection established from mail-qe0-f49.google.com[209.85.128.49]: TLSv1 with cipher ECDHE-RSA-RC4-SHA (128/128 bits)
Mar 27 14:56:40 control postfix/smtpd[3419]: NOQUEUE: reject: RCPT from mail-qe0-f49.google.com[209.85.128.49]: 450 4.1.1 <test@mydomain.com>: Recipient address rejected: User unknown in virtual mailbox table; from=<myname@gmail.com> to=<test@mydomain.com> proto=ESMTP helo=<mail-qe0-f49.google.com>
Mar 27 14:56:40 control postfix/smtpd[3419]: disconnect from mail-qe0-f49.google.com[209.85.128.49]

What I want is to get something like this to the sender:
Mail Delivery Subsystem <mailer-daemon@googlemail.com>
Delivery to the following recipient failed permanently:

example@domain.tld

Technical details of permanent failure:
Google tried to deliver your message, but it was rejected by the server for the recipient domain doman.tld by smtp.domain.tld. [1.2.3.4].

The error that the other server returned was:
550 5.1.1 <example@domain.tld>: Recipient address rejected: User unknown

----- Original message -----

Any help is appreciated.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 10:56
Postfix SMTP Auth to Dovecot Not Working -- HELP! Scratchpad Server Operation 6 12th April 2011 13:29
All my mail is going to /var/mail/vmail _sluimers_ Installation/Configuration 21 10th January 2011 13:21
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07


All times are GMT +2. The time now is 14:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.