Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th March 2013, 03:27
researcher7 researcher7 is offline
Junior Member
 
Join Date: Mar 2013
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default Internal Server Error Immediately After Installation.

(If this was answered before, please excuse this message and point me to where I can read about it)

Please help, I am about to lose my sanity.
Just finished installing ISPConfig 3 following the steps in this article.

http://www.howtoforge.com/perfect-se...ot-ispconfig-3

Not a single error or problem encountered during the install.
Now going to https://myipaddress:8080
I see "Internal Server Error" messages.

Here is what I can collect from logs and file versions.

[/var/log/httpd]# tail -f error_log
suexec policy violation: see suexec log for more details
[Mon Mar 25 05:16:12 2013] [warn] [client x.x.x.x] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
[Mon Mar 25 05:16:12 2013] [error] [client x.x.x.x] Premature end of script headers: index.php


[/var/log/httpd]# tail -f suexec.log
[2013-03-25 05:17:21]: uid: (32014/ispconfig) gid: (32017/ispconfig) cmd: .php-fcgi-starter
[2013-03-25 05:17:21]: command not in docroot (/var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter)

[/var/log/httpd]# suexec -V
-D AP_DOC_ROOT="/home"
-D AP_GID_MIN=100
-D AP_HTTPD_USER="apache"
-D AP_LOG_EXEC="/var/log/httpd/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=500
-D AP_USERDIR_SUFFIX="public_html"


root@www [/var/log/httpd]# httpd -V
Server version: Apache/2.2.15 (Unix)
Server built: May 16 2012 22:32:26
Server's Module Magic Number: 20051115:24
Server loaded: APR 1.3.9, APR-Util 1.3.9
Compiled using: APR 1.3.9, APR-Util 1.3.9
Architecture: 64-bit
Server MPM: Prefork
threaded: no
forked: yes (variable process count)
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D DYNAMIC_MODULE_LIMIT=128
-D HTTPD_ROOT="/etc/httpd"
-D SUEXEC_BIN="/usr/sbin/suexec"
-D DEFAULT_PIDLOG="run/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"

This is
CentOS release 6.4 x64

Thank you for your time and assistance.
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2013, 00:05
researcher7 researcher7 is offline
Junior Member
 
Join Date: Mar 2013
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone?
I tried everything in the book. Removed and completely re-installed. Still get the same error.

Thank you.
Reply With Quote
  #3  
Old 26th March 2013, 08:26
researcher7 researcher7 is offline
Junior Member
 
Join Date: Mar 2013
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Never mind. Just saw the sticky notice. I'll move this post to the right forum, but the initial link sends to here.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help cant access anything locally or from ip jimmie Installation/Configuration 14 5th March 2013 07:58
500 internal error after upgrade abintipl Installation/Configuration 9 18th July 2012 12:51
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 22:53
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 02:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.