Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th March 2013, 13:38
wck wck is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default [Solved] smtp sasl authentication failure, no explanation

Hi,

Running ISPconfig 3 on Ubuntu Server 12.04 LTS (Perfect server guide Howto)
ISPconfig is up to date and I allowed it to reconfigure services.

I cannot send emails through my server. After trying to connect via Gmail, the logs show :

Code:
Mar 24 13:14:07 servername postfix/submission/smtpd[16901]: connect from mail-ie0-f178.google.com[209.85.223.178]
Mar 24 13:14:07 servername dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
Mar 24 13:14:09 servername postfix/submission/smtpd[16901]: warning: mail-ie0-f178.google.com[209.85.223.178]: SASL PLAIN authentication failed: 
Mar 24 13:14:09 servername postfix/submission/smtpd[16901]: disconnect from mail-ie0-f178.google.com[209.85.223.178]
After a lot of Googling I see there is generally an explanation after "authentification failed: " but here, there is none.

Something else I've tried to check saslauthd :

Code:
testsaslauthd -u user@domain.com -p password -s smtp
0: NO "authentication failed"
Any help would be greatly appreciated.

Last edited by wck; 24th March 2013 at 16:48.
Reply With Quote
Sponsored Links
  #2  
Old 24th March 2013, 16:47
wck wck is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Well... problem solved.

Most tutorials about this problem mention smtpd.conf (which didn't exist on my server...) but the authentication code is actually in /etc/dovecot/dovecot-sql.conf

In this file, the SQL query has an extra "AND disable%Ls = 'n'" compared to what's usually in smtpd.conf and I realized `disablesmtp` was set to 'y' for the account I was trying to use (in dbispconfig.mail_user).

So, two solutions :
- manually set `disablesmtp` to 'n'
or
- check "enable receiving" in the settings for this email mailbox (although I'm using it purely to send email, not receiving).

testsaslauthd still tells me "authentication failed"... but eh, it works.

Last edited by wck; 24th March 2013 at 16:51.
Reply With Quote
Reply

Bookmarks

Tags
dovecot, saslauthd, smtp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
SASL LOGIN authentication failed Captain Installation/Configuration 4 13th March 2012 20:07
Mail hold in Q fisherofer Installation/Configuration 1 5th February 2012 13:29
Need help with ISPConfig Mail and Squirrelmail m.xander Installation/Configuration 109 3rd February 2012 00:15
Fail2ban + sasl problem and Solution pititis General 1 2nd March 2011 07:02


All times are GMT +2. The time now is 11:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.