Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th September 2012, 14:04
pcboyau pcboyau is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Unable to read server configuration from database.

Hi all

having some problems doing an update on a multi server setup. i've been able to update my master server my primary servers updated fine and also update the slave mail fine but for some reason the slave web server does not want to update.

I've checked the config files and checked that the mysql database details work from the shell to the master database also checked the server_id is correct in the config.... i'm at a loss

I'm going from 3.0.4.2 to 3.0.4.6

anyone got any ideas?


oh snap this should be in ispconfig3 Sorry

Last edited by pcboyau; 4th September 2012 at 14:06. Reason: oh snap this should be in ispconfig3
Reply With Quote
Sponsored Links
  #2  
Old 4th September 2012, 14:13
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,578
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

As the error message says, the server configuration can not be retrieved from the local database. Check that a record with the server_id that you find in the /usr/local/ispconfig/server/lib/config.inc.php exists in the local dbispconfig database of the slave server and that this records has a valid ini style configuraton in the 'config' field. If the ini style info is missing on the slave, copy it from the server record of this server that you find in the master database.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 4th September 2012, 15:03
pcboyau pcboyau is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy

Checked the database and the Servers table looks fine. the config cell for that server looks fine as well.

I've compared the cells from the server table on both the mast and the slave and they are the same

local access to the local database looks fine from the command line .. any other ideas?
Reply With Quote
  #4  
Old 4th September 2012, 15:09
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,578
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

There must be a problem with the content of the config cell as it an not be parsed which throws this error. Copy the content of the config field into a text editor and check if the format is ok. Ini sytsle format can contain section in this format:

[section]

and inside the sections key value paisr like this:

key=value
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 4th September 2012, 15:18
pcboyau pcboyau is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

send you the configs via PM

thx
Reply With Quote
  #6  
Old 4th September 2012, 15:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,578
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

The config seems to be ok. And you are really sure that the mysql root password in the file /usr/local/ispconfig/server/lib/mysql_clientdb.conf AND the ispconfig password for the local database /usr/local/ispconfig/server/lib/config.inc.php are correct?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 4th September 2012, 15:30
pcboyau pcboyau is offline
Junior Member
 
Join Date: Mar 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yeah just double checked and confirmed that they are working fine.

checked the local root - working from the config details
checked the master root - working from the config details
checked the local ispconfig - working from the config details

Reply With Quote
  #8  
Old 4th September 2012, 15:43
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,578
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Then you can just try to debug the isuue on your server, the installer is not able to get the system configuration and stops so that your system does not get damaged. The code is in the file install/lib/update.lib.php on line 120. The issue is quite uncommon as I do ISPConfig updates daily and did not had it on a server yet.

If you are not able to debug that yourself, then you might want to contact the ispconfig support:

http://support.projektfarm.com/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 4th September 2012 at 15:45.
Reply With Quote
  #9  
Old 21st March 2013, 17:09
EntireNet EntireNet is offline
Junior Member
 
Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Cool Update issues

Hi all,

i have similar problems updating a multiserver setup.

In mysql.log i see that the update script is querying the local db of the master server. The last entries in /var/log/mysql/mysql.log before the script stops with "Unable to read server configuration from database." is:

199 Query SELECT * FROM dbispconfig.server WHERE server_id = 1
199 Quit
202 Quit

I'm using 3.0.4.6 version of ICPConfig.

What else can i check?

Since all service are running fine on the dedicated web and ftp, mail and database server, i assume the mysql connections and privileges are all fine.

Regards,

EntireNet
Reply With Quote
  #10  
Old 21st March 2013, 20:15
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
 
Default

I'm seeing weird MySQL problems on several servers that might be related.
Maybe Oracle finally had enough
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 10:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.