#1  
Old 19th March 2013, 16:23
mcaramb mcaramb is offline
Junior Member
 
Join Date: Jun 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default 8080 has no VirtualHosts

Trying to access my admin page from outside the intranet, but I don't think ISPCONFIG3 has setup the proper apache2 routing for port 8080 to the server web address.

The server's name is tesla.designwizardry.com, and I've setup a site with that domain, and it resolves properly to the public IP, and I can see the html at 80, but I am only able to hit the admin page at https://192.168.0.123:8080, locally, rather than the https://tesla.designwizardry.com:8080

Of course, I've already checked that NAT from public IP 8080 is routed to local IP 8080 in the router

When I restart apache2, I get NameVirtualHost 192.168.0.123:8080 has no VirtualHosts which is why I think I must have missed a configuration step somewhere, and it's gone and set up the admin php in the root /var/www

Any ideas?
Thanks,
Mike
Reply With Quote
Sponsored Links
  #2  
Old 19th March 2013, 16:50
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Please, post file content:
/etc/apache2/sites-available/ispconfig.vhost
/etc/apache2/sites-available/ispconfig.conf
/etc/apache2/ports.conf





You can just simple update the panel... It may fix the problem.
Reply With Quote
  #3  
Old 19th March 2013, 20:54
mcaramb mcaramb is offline
Junior Member
 
Join Date: Jun 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks, but how do I do update the panel? I'm not sure what you're referring to...But here's my config files...


PORTS.CONF
---------------

# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>


ISPCONFIG.VHOST
---------------------

################################################## ####
# This virtual host contains the configuration
# for the ISPConfig controlpanel
################################################## ####

Listen 8080
NameVirtualHost *:8080

<VirtualHost _default_:8080>
ServerAdmin webmaster@localhost

<FilesMatch "\.ph(p3?|tml)$">
SetHandler None
</FilesMatch>

<IfModule mod_fcgid.c>
DocumentRoot /var/www/ispconfig/
SuexecUserGroup ispconfig ispconfig
<Directory /var/www/ispconfig/>
Options Indexes FollowSymLinks MultiViews +ExecCGI
AllowOverride AuthConfig Indexes Limit Options FileInfo
AddHandler fcgid-script .php
FCGIWrapper /var/www/php-fcgi-scripts/ispconfig/.php-fcgi-starter .php
Order allow,deny
Allow from all
</Directory>
IPCCommTimeout 7200
</IfModule>

# <IfModule mod_php5.c>
# DocumentRoot /usr/local/ispconfig/interface/web/
# AddType application/x-httpd-php .php
# <Directory /usr/local/ispconfig/interface/web>
# # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
# Options FollowSymLinks
# AllowOverride None
# Order allow,deny
# Allow from all
# php_value magic_quotes_gpc 0
# </Directory>
# </IfModule>

# ErrorLog /var/log/apache2/error.log
# CustomLog /var/log/apache2/access.log combined
ServerSignature Off

<IfModule mod_security2.c>
SecRuleEngine Off
</IfModule>

# SSL Configuration
SSLEngine On
SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
#SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle

</VirtualHost><Directory /var/www/php-cgi-scripts>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<Directory /var/www/php-fcgi-scripts>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

ISPCONFIG.CONF
-------------------


################################################
# ISPConfig Logfile configuration for vlogger
################################################

LogFormat "%v %h %l %u %t \"%r\" %>s %B \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "| /usr/local/ispconfig/server/scripts/vlogger -s access.log -t \"%Y%m%d-access.log\" /var/log/ispconf$

<Directory /var/www/clients>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

# Do not allow access to the root file system of the server for security reasons
<Directory />
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

<Directory /var/www/conf>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>

# Except of the following directories that contain website scripts
<Directory /usr/share/phpmyadmin>
Order allow,deny
Allow from all
</Directory>

<Directory /usr/share/phpMyAdmin>
Order allow,deny
Allow from all
</Directory>

<Directory /usr/share/squirrelmail>
Order allow,deny
Allow from all
</Directory>

# Allow access to mailman on OpenSuSE
<Directory /usr/lib/mailman/cgi-bin>
AllowOverride All
order allow,deny
allow from all
</Directory>

<Directory /usr/lib/mailman/icons>
order allow,deny
allow from all
</Directory>

<Directory /var/lib/mailman/archives/>
Options +FollowSymLinks
order allow,deny
allow from all
</Directory>

# allow path to awstats and alias for awstats icons
<Directory /usr/share/awstats>
Order allow,deny
Allow from all
</Directory>

Alias /awstats-icon "/usr/share/awstats/icon"

NameVirtualHost 192.168.0.123:80
NameVirtualHost 192.168.0.123:443
NameVirtualHost 192.168.0.123:8080
NameVirtualHost 98.175.16.147:80
NameVirtualHost 98.175.16.147:443
NameVirtualHost 98.175.16.147:8080
Reply With Quote
  #4  
Old 20th March 2013, 09:21
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Files are OK.

Just try to update the panel...

cd /tmp
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php
Reply With Quote
  #5  
Old 20th March 2013, 13:47
mcaramb mcaramb is offline
Junior Member
 
Join Date: Jun 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Updated the panel. But Still not working. Am I right in assuming it doesn't matter which domain I point to, that all 8080 traffic is routed to the var/www ?

I'm still getting:


[Wed Mar 20 07:43:18 2013] [warn] NameVirtualHost 192.168.0.123:8080 has no VirtualHosts


when I restart apache2

-Mike
Reply With Quote
  #6  
Old 20th March 2013, 14:09
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Quote:
Originally Posted by mcaramb View Post
Updated the panel. But Still not working. Am I right in assuming it doesn't matter which domain I point to, that all 8080 traffic is routed to the var/www ?

I'm still getting:


[Wed Mar 20 07:43:18 2013] [warn] NameVirtualHost 192.168.0.123:8080 has no VirtualHosts


when I restart apache2

-Mike

Code:
[Wed Mar 20 07:43:18 2013] [warn] NameVirtualHost 192.168.0.123:8080 has no VirtualHosts
is not a problem.


Code:
Am I right in assuming it doesn't matter which domain I point to, that all 8080 traffic is routed to the var/www
All traffic from port 8080 will be sent to /var/www/ispconfig/ -> /usr/local/ispconfig/interface/


Are you sure, that it is not a problem with your modem/firewall/router ? Port 8080 must be open in it.
Reply With Quote
  #7  
Old 20th March 2013, 14:25
mcaramb mcaramb is offline
Junior Member
 
Join Date: Jun 2009
Posts: 17
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

The router was my prime suspect, but it seemed to be configured properly.

HOWEVER... just in case, I just re-ran the update.php and this time changed the admin port to 81 instead of 8080 and made the change in my router NAT tables, and surprise! It's working now.

Apparently, my router's 8080 port is being used somewhere higher up than the NAT tables, likely for it's own config, which is odd, cause that's not the port I config my router on.

I'll have to dig into the command line interface to find out whats commandering port 8080

thanks for your help!
-Mike
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPC3 Cronlog and GUI errors crypted General 4 14th February 2011 09:59
web address loading wrong website crypted General 19 2nd December 2010 07:26
webdav + new ispc3 support + debian? crypted Installation/Configuration 6 19th October 2010 17:25
Apache errors foxfirediego Server Operation 3 5th September 2009 00:57
Apache2 Errors Web-Sites Won't Load giganet Installation/Configuration 4 1st January 2009 19:00


All times are GMT +2. The time now is 12:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.