Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 18th March 2013, 07:22
asterinux asterinux is offline
Junior Member
 
Join Date: Aug 2012
Posts: 18
Thanks: 5
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by dclardy View Post
I have added Ubuntu support to this now. I used the latest how-to from Falko to get it working. I have also cleaned up the Debian install some. I will be working more on it in the next few weeks.
hi dclardy, first of all i want to thank you for creating this script, been looking for some automation script to install ispconfig3, i salute you for this . I have only a follow-up question sir, is the script for CentOS complete?


Thanks.
Reply With Quote
Sponsored Links
  #22  
Old 18th March 2013, 07:49
asterinux asterinux is offline
Junior Member
 
Join Date: Aug 2012
Posts: 18
Thanks: 5
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by asterinux View Post
hi dclardy, first of all i want to thank you for creating this script, been looking for some automation script to install ispconfig3, i salute you for this . I have only a follow-up question sir, is the script for CentOS complete?


Thanks.
hi dclardy, nevermind.. i already read instructions in github, thanks
Reply With Quote
  #23  
Old 18th March 2013, 14:29
almere almere is offline
ISPConfig Developer
 
Join Date: Nov 2012
Location: Netherlands, Rotterdam
Posts: 231
Thanks: 20
Thanked 39 Times in 34 Posts
Send a message via Skype™ to almere
Default

Quote:
Originally Posted by wcsing View Post
Thanks for this script, It do save a lot of time.

I do have a small problem after running the script, The web site that i have created by ISP3 has shown the /var/www/index.html and not the /var/www/clients/client1/tadj.com/web/index.html.

can you give me some idea how to correct it? Thanks.
If you have multi IP's at your server, make sure that DNS A record has the same IP as vhost.
Reply With Quote
The Following User Says Thank You to almere For This Useful Post:
bpatrickmittle222 (19th July 2013)
  #24  
Old 18th March 2013, 16:27
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Quote:
Originally Posted by asterinux View Post
hi dclardy, first of all i want to thank you for creating this script, been looking for some automation script to install ispconfig3, i salute you for this . I have only a follow-up question sir, is the script for CentOS complete?


Thanks.
The script is not complete, but I am working on it. I don't use CentOS, and it is harder for me to get this done. I will be spinning up a test box to try and get it going.
Reply With Quote
The Following User Says Thank You to dclardy For This Useful Post:
asterinux (19th March 2013)
  #25  
Old 17th July 2013, 20:19
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Alright. It has been awhile since I have updated the script any, but I have made some major changes.

Please let me know what you think.

Changes:
1. Add latest Debian and Ubuntu Support
2. Added Whiptail for prompts. (Looks way cleaner!)

In Progress:
1. RoundCube Support
2. Theme Installation Support
Reply With Quote
The Following User Says Thank You to dclardy For This Useful Post:
ruchri (5th October 2013)
  #26  
Old 23rd July 2013, 18:13
Theseus Theseus is offline
Junior Member
 
Join Date: Jul 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig Script

I am interested in a version of this script for openSUSE 12.3. I have not been able to get the install instructions to work. I am able to execute all the instructions for version 12.2 (with the appropriate modifications in the links), but when I run https://192.168.1.100:8080 I don't get the login screen shown in the tutorial. Just two options:

Skip to the navigation. Skip to the content.

If anyone knows what's wrong, I would appreciate it, or a copy of that script for opensuse.
Reply With Quote
  #27  
Old 21st August 2013, 16:29
dclardy dclardy is offline
Senior Member
 
Join Date: Sep 2009
Location: Dallas, TX
Posts: 347
Thanks: 10
Thanked 47 Times in 28 Posts
Default

Quote:
Originally Posted by dclardy View Post
Alright. It has been awhile since I have updated the script any, but I have made some major changes.

Please let me know what you think.

Changes:
1. Add latest Debian and Ubuntu Support
2. Added Whiptail for prompts. (Looks way cleaner!)

In Progress:
1. RoundCube Support
2. Theme Installation Support
Alright. I have gotten RoundCube Installation support added in. It is a different bash script. Please test this out. I have several times, but I might have missed something.

I am working on the Theme Installation part of it. Initially, I will probably only install my theme, but I am a little biased in that regard!
Reply With Quote
The Following 2 Users Say Thank You to dclardy For This Useful Post:
almere (21st August 2013), ruchri (5th October 2013)
  #28  
Old 27th September 2013, 15:37
stevenlib stevenlib is offline
Junior Member
 
Join Date: Aug 2013
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
Default Some errors

Hi,

It fails on Wheezy, I get this:

Thu Sep 26 11:55:02 EDT 2013 --2013-09-26 11:55:02-- http://repo.web-wack.at/ispconfig3/d...g3/0.0.0.2.zip
Thu Sep 26 11:55:02 EDT 2013 Resolving repo.web-wack.at (repo.web-wack.at)... 94.23.161.144
Thu Sep 26 11:55:02 EDT 2013 Connecting to repo.web-wack.at (repo.web-wack.at)|94.23.161.144|:80... connected.
Thu Sep 26 11:55:02 EDT 2013 HTTP request sent, awaiting response... 200 OK
Thu Sep 26 11:55:02 EDT 2013 Length: 126842 (124K) [application/zip]
Thu Sep 26 11:55:02 EDT 2013 Saving to: `0.0.0.2.zip'
Thu Sep 26 11:55:02 EDT 2013
Thu Sep 26 11:55:03 EDT 2013 0K .......... .......... .......... .......... .......... 40% 238K 0s
Thu Sep 26 11:55:03 EDT 2013 50K .......... .......... .......... .......... .......... 80% 449K 0s
Thu Sep 26 11:55:03 EDT 2013 100K .......... .......... ... 100% 5.84M=0.3s
Thu Sep 26 11:55:03 EDT 2013
Thu Sep 26 11:55:03 EDT 2013 2013-09-26 11:55:03 (380 KB/s) - `0.0.0.2.zip' saved [126842/126842]
Thu Sep 26 11:55:03 EDT 2013
Thu Sep 26 11:55:03 EDT 2013 sh: ./setup.sh: Permission denied

Then it says the install failed in ISPConfig logs.

Regards,
Reply With Quote
  #29  
Old 5th October 2013, 22:02
ruchri ruchri is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by dclardy View Post
Alright. I have gotten RoundCube Installation support added in. It is a different bash script. Please test this out.
Works fine on Debian 7 64b Wheezer.

Thank you!

Last edited by ruchri; 5th October 2013 at 22:03. Reason: added 'Thank you!'
Reply With Quote
  #30  
Old 5th October 2013, 23:47
ruchri ruchri is offline
Junior Member
 
Join Date: Oct 2011
Posts: 3
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default Why restarting Apache2 manually after VPS reboot?

Quote:
Originally Posted by dclardy View Post
Alright. It has been awhile since I have updated the script any, but I have made some major changes.

Please let me know what you think.

Changes:
1. Add latest Debian and Ubuntu Support
There is one small issue: after each reboot of my VPS I have to restart apache2 manually: /etc/init.d/apache2 restart

I don't understand why, so I can't find a solution for that.

VPS, 1 GB memory - Debian 7 64bit
Installed ISPConfig3 and Roundcube with your install scripts and there were no errors or whatsoever.
Everything is working nice and smoothfull, as I already stated elsewhere in this topic.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 18:17
use jawstats / mawstats with ispconfig e100 Tips/Tricks/Mods 3 19th December 2010 11:33
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42
ISPConfig Install Error badenzer Installation/Configuration 2 23rd June 2006 00:20


All times are GMT +2. The time now is 10:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.