Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 16th March 2013, 21:26
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 187
Thanks: 39
Thanked 4 Times in 4 Posts
Post Stupid mistake by LinuxUser Wannabe -> The Perfekt Server - ISPConfig - Ubuntu 10.04

*** NOT RELEVANT ANYMORE ***

Dear Falko & HowToForge Staff and members...

First of all, thanks for a great tutorial. I feel almost capable using this tutorial

1. I am following your tutorial The Perfekt Server - ISPConfig 2 - Ubuntu 10.04 to make a webserver for my projekt on UNI in Denmark, my personal website and for testing HTML stuff. This is all good, but, having reached chapter 16 I just discovered that I made a stupid mistake! In the tutorial we are told that regarding IPnumber, servername etc. we will have to replace it using our own setup - and that this servername is what you used your system: server1.example.com. I replaced the IPnumber with my machine IP, But I only corrected the servername not the domain, thinking that mayby this was done later on. But having reached chapter 16 I now know better! (sample: server1.exaple.com - my replacement: webserver1.exaple.com) My server is called, as you see webserver1 to be used with mydomain.tld and therefore I am announcing myself as the sucker of the year. But please help me.
I have been going trough he toturial from the beginning and found that correcting (chapter 7) /etc/host with both my servername and mydomain.dk will correct it here. To restart with the right information is this ok?
echo webserver1.mydomain.dk > /etc/hostname
/etc/init.d/hostname restart

then
hostname
hostname -f

The next place I found the error is in chapter: 15 Postfix With SMTP-AUTH And TLS. Will it be necessary to do the whole chapter again? And if, what is the rigt place to be located in the prompt. Right now I am root@webserver1:/etc/postfix/ssl# - does it matter at all when we are using the commands that we do?

2. Another thing I was trying hard get through was also in chapter 15. (Afterwards we create the certificates for TLS
mkdir /etc/postfix/ssl
cd /etc/postfix/ssl/
openssl genrsa -des3 -rand /etc/hosts -out smtpd.key 1024

After the last line I was asked to: "enter pass phrase for smtpd.key" I did not known if this was another user/password situation like with MySQL - so I looked for Info onLine to find some answers, and this is where I found the best answer. If it is the right answer I am not certain about.: http://www.wellcrafted.de/wiki/rootserver/mail
Regarding some of the question you are asked I was very confused - this because it is not obvious to beginners what to enter. According to the website mentioned above this is where you enter information regarding your smtp server and a postmaster@mydomain.tld:
# Common Name (eg, YOUR name) []: <-- here you enter the DNS name of the SMTP server
# Email Address []: <-- typically something like postmaster@yourdomain.tld

Is this Infomation needed at all? Is it not possible to edit it later on via the controlpanel ISP?

Thank you for listening to me - I am looking so much forward to your response
PS. Thanks for making it possible for guys like me to have a chance building a real webserver...

Sincerely Yours
DanHansen@Denmark

Last edited by danhansen@denmark; 17th March 2013 at 01:55. Reason: Changing to ISPConfig3 - Choosed ISPConfig2 to be sure it would run on my system but I could not find manual for installation
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Debian 5 Ajax error + network interface always shutting down ev0css Installation/Configuration 3 5th June 2010 12:58
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 12:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.