Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 11th June 2006, 15:53
TheRudy TheRudy is offline
Senior Member
 
Join Date: Dec 2005
Posts: 216
Thanks: 1
Thanked 7 Times in 5 Posts
Default RAID 1, debian, installation small problem

Hey

Well my sata disks are recognized by installer and now i'm in the next painfull step of creating RAID 1.

Using this tutorial: http://www.howtoforge.com/linux_software_raid it stops for me when it tries to create an array.
"No RAID partitions available"

All four partitions for 1 disk in total 8 partitions are set for RAID!

So i went to console (ALT+F2) and typed:

mknod /dev/md0 b 9 0
mdadm --create -l 1 -n 2 /dev/md0 /dev/sda1 /dev/sdb1

and array was successfully created:
cat /proc/mdstat gives me an md0 array..

Now i wanted to do this for all other 3 partitions (in total i have 4) using same steps:
mknod /dev/md1 b 9 0
mdadm --create -l 1 -n 2 /dev/md1 /dev/sda2 /dev/sdb2

It asks me for creating array, i type 'yes' and then it gives me an error:
mdadm: SET_ARRAY_INFO failed for /dev/md1: Invalid argument

Going back to first console, installation still gives me "no raid partitions available". Anyone knows what's going on here? Some hints would be appriciated..

Last edited by TheRudy; 11th June 2006 at 15:57.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
How to setup Debian linux on a Dell server with RAID 1 Hans HOWTO-Related Questions 7 11th May 2006 00:10
I have a small problem with this tutorial :Building A Debian DNS System ajoian HOWTO-Related Questions 1 25th February 2006 12:28
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42
Installation problem xma Installation/Configuration 15 26th September 2005 13:22


All times are GMT +2. The time now is 04:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.