Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th March 2013, 23:53
supanatral supanatral is offline
Member
 
Join Date: Mar 2010
Posts: 38
Thanks: 1
Thanked 4 Times in 4 Posts
Default PHP Website Not Displaying correctly

I'm trying to websites from an old Linux RHEL 8.0 server to a new ISPConfig server but there are a few websites giving me trouble. I've confirmed that the database is contactable and I've setup the database to be the same database name, username and password.

If you take a look at the one that's displaying improperly (running on ISPConfig), I noticed that there is a link to a picture that isn't showing. When I checked the picture URL, this is what I get:
Quote:
http://domain.com/phpThumb/phpThumb.php?src=images/products/%3C?=%20mysql_result($rs,$i,
On the server thats displaying correctly, the link to a picture shows as the following:
What could be the cause of this?
Attached Images
  
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2013, 18:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

I guess PHP versions differ on both servers, and the programming is not compatible with newer PHP versions.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th March 2013, 19:50
supanatral supanatral is offline
Member
 
Join Date: Mar 2010
Posts: 38
Thanks: 1
Thanked 4 Times in 4 Posts
Default

Thanks for your response.

I logged into the old web server and found PHP version 5.1.0 installed and on my ISPConfig, I have version 5.3.3 installed.

Is it possible to install both versions of PHP on the server?
Reply With Quote
The Following User Says Thank You to supanatral For This Useful Post:
Al-Muntaqim (10th March 2013)
  #4  
Old 9th March 2013, 21:05
supanatral supanatral is offline
Member
 
Join Date: Mar 2010
Posts: 38
Thanks: 1
Thanked 4 Times in 4 Posts
Default

Update: I found another server (running Windows Server) that had an old version of PHP when I tried hosting the website on this server, it worked.

Although this is somewhat of a success and allows me to completely retire the old Linux server, I am still very interested in migrating the website to the ISPConfig server if possible since the Windows Server is nearing retirement as well. Not to mention, the Windows server doesn't have MySQL installed on it so it's currently using the ISPConfig server as a database server which will create confusion in the future.

Once again, is it possible to install PHP 5.1.0 on my ISPConfig server?

Last edited by supanatral; 9th March 2013 at 22:08.
Reply With Quote
  #5  
Old 11th March 2013, 12:39
ressel ressel is offline
Senior Member
 
Join Date: Apr 2007
Location: Denmark
Posts: 128
Thanks: 18
Thanked 5 Times in 5 Posts
 
Default

Quote:
Originally Posted by supanatral View Post
Update: I found another server (running Windows Server) that had an old version of PHP when I tried hosting the website on this server, it worked.

Although this is somewhat of a success and allows me to completely retire the old Linux server, I am still very interested in migrating the website to the ISPConfig server if possible since the Windows Server is nearing retirement as well. Not to mention, the Windows server doesn't have MySQL installed on it so it's currently using the ISPConfig server as a database server which will create confusion in the future.

Once again, is it possible to install PHP 5.1.0 on my ISPConfig server?
It should be...
http://www.php.net/releases/
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 10:29
Really Simple DNS Question andysm849 Server Operation 4 21st October 2008 00:32
How to add a subdomain? malinens Installation/Configuration 2 11th March 2008 00:16
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 10:54
php script injections Grizzly General 21 18th July 2006 09:55


All times are GMT +2. The time now is 07:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.