Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd February 2013, 15:56
Gijs Gijs is offline
Member
 
Join Date: Feb 2013
Posts: 54
Thanks: 20
Thanked 2 Times in 2 Posts
Default Database backup ISPConfig 3.0.5 RC2

Hi,

I installed ISPConfig 3.0.5 RC2 and it says that the backup should include the database which is beautifull but if I choose "download" in the backup section, the backup included in the /backup doesn't contain the database file which is less beautifull I think.

Am I doing something wrong or is the database only included in the restore process?

Thanks for the answer.
Reply With Quote
Sponsored Links
  #2  
Old 22nd February 2013, 22:43
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

You should assign database to your website to have the database backup, if yours is a old installation, you have to do it manually for every website.

For newer website the ispconfig will automatically ask you to assign the database.
Reply With Quote
The Following User Says Thank You to pawan For This Useful Post:
Gijs (23rd February 2013)
  #3  
Old 23rd February 2013, 14:03
Gijs Gijs is offline
Member
 
Join Date: Feb 2013
Posts: 54
Thanks: 20
Thanked 2 Times in 2 Posts
Default

Thats it! Thanks for the help
Reply With Quote
  #4  
Old 26th February 2013, 12:56
Gijs Gijs is offline
Member
 
Join Date: Feb 2013
Posts: 54
Thanks: 20
Thanked 2 Times in 2 Posts
Default

Hi Pawan,

I thought that was the solution but it isn't. The database is still not backuped. If I download the backup file it contains only the FTP data. The database is not included in there.

Do you have any other suggestions?

Thanks again
Reply With Quote
  #5  
Old 26th February 2013, 13:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Backups are created nightly. Have you waited until the next day before you tried the download again?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 26th February 2013, 14:17
Gijs Gijs is offline
Member
 
Join Date: Feb 2013
Posts: 54
Thanks: 20
Thanked 2 Times in 2 Posts
Default

Well, their are also backups made this night and they don't include the databases either. And it is a fresh website created on the 3.0.5 final.

Their don't have to be any specific settings right? Just create a database user, the database and the website isn't it?
Reply With Quote
  #7  
Old 26th February 2013, 14:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Quote:
Their don't have to be any specific settings right? Just create a database user, the database and the website isn't it?
Yes. Please check that the applications sudo and mysqldump are installed on your server and that the mysql root password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf is correct and does not contain any special chars.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Gijs (26th February 2013)
  #8  
Old 26th February 2013, 14:31
Gijs Gijs is offline
Member
 
Join Date: Feb 2013
Posts: 54
Thanks: 20
Thanked 2 Times in 2 Posts
Default

Aha, mysql_clientdb.conf says that the mysql database is localhost, but it is not, so that should be the solution.
I will have to wait for the next backup tonight but thanks so far again!
Reply With Quote
  #9  
Old 4th March 2013, 14:43
Gijs Gijs is offline
Member
 
Join Date: Feb 2013
Posts: 54
Thanks: 20
Thanked 2 Times in 2 Posts
Default

It's working now!
External MySQL backup still didn't work but I didn't see any good reason to use an external database so I am using the local MySQL database now and that works with the backup.
Reply With Quote
  #10  
Old 17th January 2014, 14:22
arraken arraken is offline
Member
 
Join Date: Mar 2010
Posts: 91
Thanks: 13
Thanked 3 Times in 3 Posts
 
Default

Hi,

In my multiserver setup, the db backup also doesn't work. The webserver is on a different server than the db server. I have updated my mysql_clientdb.conf file accordingly:

Code:
<?php

$clientdb_host                  = 'db1.domain.tld';
$clientdb_user                  = 'root';
$clientdb_password              = 'rootpassword for mysql on db1';

?>
Mysqldump and sudo is installed on both servers.

However, if I do:
Code:
mysqldump -h db1.domain.tld -u root -p c1testdb1 > c1testdb.dump
I get:
Code:
 Access denied for user 'root'@'web1.domai.tld' (using password: YES) when trying to connect
Does that indicate the problem?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 20:03
around 80 sleeping connections created by ISPConfig bkilinc General 2 1st October 2012 16:12
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Online Backup : What do you use and how do you setup it ? XZed Technical 5 4th January 2010 18:02
Setting up a backup mail server setup with two installations of ISPConfig zitch Tips/Tricks/Mods 7 30th December 2006 10:07


All times are GMT +2. The time now is 05:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.