Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd March 2013, 06:47
centosfan centosfan is offline
Junior Member
 
Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Can't find /etc/init.d/clamd.amavisd after install on CentOS 6.3

Hi, I have been following the instructions at

The Perfect Server - CentOS 6.3 x86_64 (Apache2, Dovecot, ISPConfig 3)
http://www.howtoforge.com/perfect-se...ispconfig-3-p4

to Install Amavisd-new, SpamAssassin And ClamAV. So ran the following command

Code:
yum install amavisd-new spamassassin clamav clamd unzip bzip2 unrar perl-DBD-mysql

sa-update
chkconfig --levels 235 amavisd on
chkconfig --del clamd
chkconfig --levels 235 clamd.amavisd on
/usr/bin/freshclam
/etc/init.d/amavisd start
/etc/init.d/clamd.amavisd start
But it could not start clamd.amavisd, so checked the /etc/init.d/ directory and it's not there. I run the yum install command again just to make sure

Code:
yum install amavisd-new spamassassin clamav clamd
and it returned

Code:
Setting up Install Process
Package amavisd-new-2.6.6-3.el6.rf.x86_64 already installed and latest version
Package spamassassin-3.3.1-2.el6.x86_64 already installed and latest version
Package clamav-0.97.6-1.el6.rf.x86_64 already installed and latest version
Package clamd-0.97.6-1.el6.rf.x86_64 already installed and latest version
Nothing to do
It's still not there. My contents for /etc/init.d/ is

Code:
drwxr-xr-x  2 root root  4096 Mar  3 02:45 .
drwxr-xr-x 10 root root  4096 Mar  2 23:11 ..
-rwxr-xr-x  1 root root  1725 Aug 18  2010 acpid
-rwxr-xr-x  1 root root  2367 Jun  8  2012 amavisd
-rwxr-xr-x  1 root root  3378 Jun 22  2012 auditd
-rwxr-xr-x  1 root root  1292 Apr 14  2011 clamd
-rwxr-xr-x  1 root root  2793 Jul 19  2011 crond
-rwxr-xr-x  1 root root  1987 May  6  2010 dovecot
-rw-r--r--  1 root root 18171 Apr 27  2012 functions
-rwxr-xr-x  1 root root  5777 Apr 27  2012 halt
-rwxr-xr-x  1 root root  3371 Feb 13  2012 httpd
-rwxr-xr-x  1 root root  8727 Feb 25  2012 ip6tables
-rwxr-xr-x  1 root root  8630 Feb 25  2012 iptables
-rwxr-xr-x  1 root root   652 Apr 27  2012 killall
-rwxr-xr-x  1 root root  5509 Jan 31 20:59 mysqld
-rwxr-xr-x  1 root root  2989 Apr 27  2012 netconsole
-rwxr-xr-x  1 root root  5485 Apr 27  2012 netfs
-rwxr-xr-x  1 root root  6334 Apr 27  2012 network
-rwxr-xr-x  1 root root  1923 Oct 22  2009 ntpd
-rwxr-xr-x  1 root root  1866 Oct 22  2009 ntpdate
-rwxr-xr-x  1 root root  2023 Apr  3  2012 portreserve
-rwxr-xr-x  1 root root  3852 Dec  3  2011 postfix
-rwxr-xr-x  1 root root  2034 Feb  4  2011 quota_nld
-rwxr-xr-x  1 root root  1559 May 20  2009 rdisc
-rwxr-xr-x  1 root root  1815 Jun 22  2012 restorecond
-rwxr-xr-x  1 root root  2011 May 17  2012 rsyslog
-rwxr-xr-x  1 root root  1698 Jun 22  2012 sandbox
-rwxr-xr-x  1 root root  2056 Nov 20 11:52 saslauthd
-rwxr-xr-x  1 root root   647 Apr 27  2012 single
-rwxr-xr-x  1 root root  1664 Aug 23  2010 spamassassin
-rwxr-xr-x  1 root root  4683 Nov  9 12:49 sshd
-rwxr-xr-x  1 root root  2276 Apr 12  2012 svnserve
-rwxr-xr-x  1 root root  2294 Jul  3  2012 udev-post
-rwxr-xr-x  1 root root  3555 Aug 13  2012 xinetd
So I tried to find it by running

Code:
find / -name "clamd.*"
but it only returned

Code:
/etc/clamd.conf 
/usr/share/doc/clamd-0.97.6/clamd.conf 
/usr/share/man/man8/clamd.8.gz 
/usr/share/man/man5/clamd.conf.5.gz

Is there any extra step that needs to be done? Or is "clamd" is the daemon that needs to be run instead?

Thank you!
Reply With Quote
Sponsored Links
  #2  
Old 4th March 2013, 19:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Maybe the name of the init script has changed. Start Clamd and check if your mail system is working.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 11th March 2013, 11:36
robin74 robin74 is offline
Junior Member
 
Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Can't find /etc/init.d/clamd.amavisd after install on CentOS 6.3

What does the following command give back to you ?
rpm -ql amavisd-new | grep clamd

for me i get this on Centos 6.4 (freshly upgraded from 6.3)
/etc/clamd.d/amavisd.conf
/etc/rc.d/init.d/clamd.amavisd
/etc/sysconfig/clamd.amavisd
/usr/sbin/clamd.amavisd
/var/spool/amavisd/clamd.sock

i hope this can help you
Reply With Quote
Reply

Bookmarks

Tags
clamav daemon

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
CentOS 6.3 - Change From Single Private IP To Multiple Public IP Block Unfaiir Installation/Configuration 3 14th February 2013 11:18
ISPconfig 3 + Centos 6.3 (64bit) GeorgeG Installation/Configuration 1 15th January 2013 17:46
Maia Mailguard with ISPconfig seangee Installation/Configuration 4 24th June 2010 10:08
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 17:22
view webalizer stats kuyaedz General 22 12th March 2006 15:45


All times are GMT +2. The time now is 20:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.