Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th February 2013, 22:30
Captain Captain is offline
Senior Member
 
Join Date: Feb 2009
Posts: 285
Thanks: 79
Thanked 7 Times in 6 Posts
Exclamation Roundcube 500 error after upgrade t0 3.0.5.1

Hello!

When I upgrade my ISP 3.0.4.6 to 3.0.5.1 on Debian6
Roundcube stop working.
in error.log:

Code:
SoftException in Application.cpp:221: File "/usr/share/roundcube/index.php" is not in document root of Vhost "/var/www/ispconfig/" 
Premature end of script headers: index.php
In apache2/conf.d I have symlink file to apache.conf for roundcube

Code:
# Those aliases do not work properly with several hosts on your apache server
# Uncomment them to use it or adapt them to your configuration
#    Alias /roundcube/program/js/tiny_mce/ /usr/share/tinymce/www/
    Alias /webmail /var/lib/roundcube
    Alias /roundcube /var/lib/roundcube

# Access to tinymce files
<Directory "/usr/share/tinymce/www/">
      Options Indexes MultiViews FollowSymLinks
      AllowOverride None
      Order allow,deny
      allow from all
</Directory>

<Directory /var/lib/roundcube/>
  Options +FollowSymLinks
  # This is needed to parse /var/lib/roundcube/.htaccess. See its
  # content before setting AllowOverride to None.
  AllowOverride All
  order allow,deny
  allow from all
</Directory>

# Protecting basic directories:
<Directory /var/lib/roundcube/config>
        Options -FollowSymLinks
        AllowOverride None
</Directory>

<Directory /var/lib/roundcube/temp>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>

<Directory /var/lib/roundcube/logs>
        Options -FollowSymLinks
        AllowOverride None
        Order allow,deny
        Deny from all
</Directory>


<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /webmail>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}:8080%{REQUEST_URI}  [L]

    </Location>
  </IfModule>

<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /roundcube>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}:8080%{REQUEST_URI}  [L]
    </Location>
  </IfModule>
</IfModule>
How can I solve it?

Thank you.

Last edited by Captain; 28th February 2013 at 22:35.
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2013, 00:17
Captain Captain is offline
Senior Member
 
Join Date: Feb 2009
Posts: 285
Thanks: 79
Thanked 7 Times in 6 Posts
Default

I reinstall roundcube - and still the same problem.
In log file same errors.

What to do?
Reply With Quote
  #3  
Old 1st March 2013, 00:35
Captain Captain is offline
Senior Member
 
Join Date: Feb 2009
Posts: 285
Thanks: 79
Thanked 7 Times in 6 Posts
Default

Problem is solved by disable suphp.
But it is not a solution.

Some one solved this problem another way?
Reply With Quote
  #4  
Old 1st March 2013, 10:06
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default

How did you disable suphp ?

did you install roundqube under a site? i have installed roundqube under /var/www/webamil and don know how to disable suphp, help plz

rgds
Marcus

Last edited by trexen; 1st March 2013 at 10:11.
Reply With Quote
  #5  
Old 1st March 2013, 10:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,389 Times in 4,234 Posts
Default

Quote:
Originally Posted by trexen View Post
How did you disable suphp ?

did you install roundqube under a site? i have installed roundqube under /var/www/webamil and don know how to disable suphp, help plz

rgds
Marcus
Which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 1st March 2013, 10:45
trexen trexen is offline
Senior Member
 
Join Date: Jun 2008
Location: Stockholm
Posts: 169
Thanks: 15
Thanked 3 Times in 2 Posts
Default

Sorry, Debian Squeeze 6 isp 3.5.1 latest
Reply With Quote
  #7  
Old 1st March 2013, 10:51
Captain Captain is offline
Senior Member
 
Join Date: Feb 2009
Posts: 285
Thanks: 79
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by trexen View Post
How did you disable suphp ?

did you install roundqube under a site? i have installed roundqube under /var/www/webamil and don know how to disable suphp, help plz

rgds
Marcus
Hello I install it under /var/www/webmail

to disable suphp:

a2dismod suphp
/etc/init.d/apache2 restart


But as I told here, in my opinion it is not a solution.
because i try to add it to open_base dir, try to modify htaccess but problemm still not solved.
Need to ask Till or Falko because it is ISPCOnfig issue.

Thank you.
Reply With Quote
The Following User Says Thank You to Captain For This Useful Post:
trexen (1st March 2013)
  #8  
Old 1st March 2013, 11:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,389 Times in 4,234 Posts
Default

Quote:
Originally Posted by Captain View Post
Hello I install it under /var/www/webmail

to disable suphp:

a2dismod suphp
/etc/init.d/apache2 restart


But as I told here, in my opinion it is not a solution.
because i try to add it to open_base dir, try to modify htaccess but problemm still not solved.
Need to ask Till or Falko because it is ISPCOnfig issue.

Thank you.

Which URL do you use to access roundcube? Dont use port 8080 to access any software beside ispconfig, for other softeware there is a apps vhost which is on port 8081 by default.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 1st March 2013, 11:29
Captain Captain is offline
Senior Member
 
Join Date: Feb 2009
Posts: 285
Thanks: 79
Thanked 7 Times in 6 Posts
Default

Hello Till!

To access to roundcube in past (on ISPCOnfig 3.0.4.6) we use https://doamin.com:8080/webmail

Now without suphp we also use this link.

As I correct understand you, now I need to reconfigure apache conf to use port 8081 for roundcube?
Correct link should be https://domain.com:8081/webmail

Code:
<IfModule mod_rewrite.c>
  <IfModule mod_ssl.c>
    <Location /webmail>
      RewriteEngine on
      RewriteCond %{HTTPS} !^on$ [NC]
      RewriteRule . https://%{HTTP_HOST}:8081%{REQUEST_URI}  [L]
    </Location>
  </IfModule>
</IfModule>
Correct?
Reply With Quote
  #10  
Old 1st March 2013, 11:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,389 Times in 4,234 Posts
 
Default

Quote:
As I correct understand you, now I need to reconfigure apache conf to use port 8081 for roundcube?
Correct link should be https://domain.com:8081/webmail
Yes.

But you dont have to deactivate suphp, instead you can also configure roundcube to use mod_php by using a setup similar to the one that we describe in the perfect server guides for squirrelmail.

For everyone who wants to deactivate suphp for global applications like webmail:

edit the file /etc/apache2/mods-available/suphp.conf and comment out the directives as described inside chapter 14:

http://www.howtoforge.com/perfect-se...ispconfig-3-p4

the procedire should work for Ubuntu and Debian Linux. Then restart apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following 3 Users Say Thank You to till For This Useful Post:
beyerservice (2nd March 2013), Captain (1st March 2013), trexen (1st March 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
500 error ispconfig controlepanel after upgrade 3.0.5 nokia80 Installation/Configuration 5 27th February 2013 13:39
nginx & wordpress gives 500 pages EckyBrazz Server Operation 8 24th October 2012 00:06
How to upgrade Roundcube 0.3 to 0.7 on Ubuntu 10.04 LTS cbj4074 Tips/Tricks/Mods 1 19th January 2012 19:50
Roundcube user plugin error next upgrade ispconfig metaldrummer Installation/Configuration 1 10th November 2011 08:48
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29


All times are GMT +2. The time now is 06:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.