Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2013, 16:09
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default Latest Update 3.0.5.1 breaks webmail

I'm getting an internal server error and getting this in my logs.

SoftException in Application.cpp:221: File "/var/www/webmail/index.php" is not in document root of Vhost "/var/www/ispconfig/"

Anyone else seen this after the latest update? I'm using roundcube as per http://www.howtoforge.com/how-to-ins...debian-squeeze

Last edited by jcombs_31; 27th February 2013 at 16:17.
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2013, 16:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,381
Thanks: 833
Thanked 5,483 Times in 4,316 Posts
Default

You can not access other applications trough the ispconfig vhost on port 8080 with the latest ispconfig version. The ispconfig vhost was never made for that. If you want to access a external application by http, create e.g. a separate vhost for it or use the ispconfig apps vhost which has been made for that.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th February 2013, 18:12
Inspi Inspi is offline
Junior Member
 
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ich habe das Problem auch gehabt und ersteinmal so gelöst:

Quote:
a2dismod suphp
Damit läuft Webmail ersteinmal bis ich es als eigene Webseite angelegt habe.
Vielleicht sollte man das Howto zum Installieren von Roundcube ebenfalls anpassen.
Reply With Quote
  #4  
Old 27th February 2013, 18:12
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default

Thanks, I changed to use the apps vhost and all it working, but had to add the SSL bindings to the vhost.
Reply With Quote
  #5  
Old 2nd March 2013, 00:26
beyerservice beyerservice is offline
Member
 
Join Date: Feb 2011
Location: /dev/null
Posts: 30
Thanks: 10
Thanked 6 Times in 5 Posts
 
Default

for someone found this after searching google for that error:

Solution:

Add red-Lines if not in your roundcube.conf file.
[...]
<Directory /var/www/roundcubemail>
Options FollowSymLinks

<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .
php_admin_value upload_tmp_dir /var/www/roundcubemail/temp
php_admin_value open_basedir /var/www/roundcubemail:/etc/hostname:/etc/mailname
php_flag register_globals off
</IfModule>



sorry for crosspost this.
Reply With Quote
The Following User Says Thank You to beyerservice For This Useful Post:
till (4th March 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horde Groupware Webmail Edition ByteMe Networking Tips/Tricks/Mods 17 20th December 2012 10:12
My Centos is terribly slow Galled Server Operation 9 7th December 2010 15:31
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19


All times are GMT +2. The time now is 05:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.