Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2013, 04:56
Parsec Parsec is offline
Member
 
Join Date: Jan 2013
Posts: 66
Thanks: 1
Thanked 9 Times in 8 Posts
Default DNS Allow zone transfers 3.0.5

Think I have encoutered a bug with 3.0.5

In the Allow zone transfers section of the dns zonefile it used to allow a comma separated list of IP's.

Now it's not happy unless there is only one IP stated there. Even existing zone records which had a comma separated list of IP's will no longer process unless only one IP is listed in this field.

Oddly, the error coming up is:
ERROR

Also notify: Please use an IP address.

I don't have anything in the "Also Notify" and even if I add an IP address there it makes no difference - same error returns.

Debian Wheezy, ISPConfig 3.0.5
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2013, 08:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Seems as if you dont use the 3.0.5 final on your server. The issue you describe existed in one of the pre releases and has been fixed in final. I just verified that you can save a zone in 3.0.5 final with empty xfer and also with empty notify field. Also adding multiple IP addresses separated by comma works fine, maybe you had some spaces between the ip addresses or a similar issue.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th February 2013, 11:31
Parsec Parsec is offline
Member
 
Join Date: Jan 2013
Posts: 66
Thanks: 1
Thanked 9 Times in 8 Posts
 
Default

Well it should be 3.0.5 final as it was downloaded using the update instructions (ie: ISPConfig 3 final).
But you are correct, seems to be a change in the method. Previously you could have a space eg: xxx.xxx.xxx.xxx, yyy.yyy.yyy.yyy - now it doesn't like the space after the comma.
Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
New domains not added to Bind9 DNS DKLeader Installation/Configuration 15 15th January 2011 21:11
How do I disable zone transfers in BIND Agent_M Installation/Configuration 5 11th July 2010 16:53
HELP DNS and DHCP I AM LOST krisarmstrong Server Operation 0 18th August 2009 23:27
Google Apps dayjahone General 19 29th March 2008 17:25
DNS Zone Transfer not complete. joelee HOWTO-Related Questions 3 19th August 2007 14:55


All times are GMT +2. The time now is 17:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.