Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th February 2013, 20:28
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default After Update Issue

Seems my websites still work, even the Proxy to mail server still works but, ispconfig on the panel server stopped working.

I did all the minor server updates of ispconfig first. then I did the panel server last (which hosts the ispconfig control panel).

The panel server is no longer responding. not on the https or http which I self created to the /var/www/ispconfig folder. I left everything default as it was on the update since I had made no changes initially except the original default port on the panel server which I changed from 8080 to 11000 (originally). But wit the update it was reset to 8080.
__________________
If you are looking for examples of an ISPConfig 3 Multiserver Setup, Visit my website Here!!!
Reply With Quote
Sponsored Links
  #2  
Old 25th February 2013, 21:29
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

Please check the apache error.log. Moste likely a part of the fastcgi setup is missing.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th February 2013, 00:57
siucdude911 siucdude911 is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation

Same issue here, and I can't access the CP anymore,

Forbidden
You don't have permission to access / on this server.


[Mon Feb 25 17:52:16 2013] [error] [client 10.0.0.103] client denied by server configuration: /var/www/

the error message and the log of the error,
It worked like a charm before the update...

This is the only other thing i found related to this error message.
http://www.howtoforge.com/forums/showthread.php?t=60025
Reply With Quote
  #4  
Old 26th February 2013, 03:22
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

I did some troubleshooting and figured out that when the update happened ISPConfig created a new virual host using port 8080 of the exact location I was using for port 80, which somehow conflicted, so I had to delete my custom port 80. given that, How can I make this work for me:

<VirtualHost ipaddress:443>
ServerName host1.domain.com
ProxyPreserveHost On
ProxyRequests Off
ProxyPass / https://privateip:8080/
ProxyPassReverse / https://privateip:8080/

SSLProxyEngine on
SSLEngine on
SSLCertificateFile /etc/ssl/certs/server.crt
SSLCertificateKeyFile /etc/ssl/private/server.key


Whenever I try to use port 443 on my webserver to forward proxy, the apache server gets an error:

Failed to start apache :

* Starting web server apache2
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
...fail!

Initially I had the control panel running on port 80. and it worked so I left it alone.
__________________
If you are looking for examples of an ISPConfig 3 Multiserver Setup, Visit my website Here!!!
Reply With Quote
  #5  
Old 26th February 2013, 05:13
siucdude911 siucdude911 is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well here is more info,
I get this after I made changes to the hostfile

[Mon Feb 25 22:08:26 2013] [error] [client 10.0.0.103] PHP Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
[Mon Feb 25 22:08:26 2013] [error] [client 10.0.0.103] PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31
Reply With Quote
  #6  
Old 26th February 2013, 08:44
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

Quote:
* Starting web server apache2
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
Action 'start' failed.
The Apache error log may have more information.
...fail!
Seems as if you have more then one Listen statement for port 80 in your apache configuration.

Quote:
Well here is more info,
I get this after I made changes to the hostfile

[Mon Feb 25 22:08:26 2013] [error] [client 10.0.0.103] PHP Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php): failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31
[Mon Feb 25 22:08:26 2013] [error] [client 10.0.0.103] PHP Fatal error: require_once(): Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31
Please post the output of:

ls -la /usr/local/ispconfig/interface/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 26th February 2013, 09:33
kendel kendel is offline
HowtoForge Supporter
 
Join Date: Aug 2010
Posts: 132
Thanks: 4
Thanked 1 Time in 1 Post
Default

the thing is, I am trying to use port 443. not 80...
__________________
If you are looking for examples of an ISPConfig 3 Multiserver Setup, Visit my website Here!!!
Reply With Quote
  #8  
Old 26th February 2013, 09:35
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
Default

Quote:
Originally Posted by kendel View Post
the thing is, I am trying to use port 443. not 80...
The error message is about port 80, not 443. So there must be a duplicate Listen statement for port 80 somewhere which prevents apache to start.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 26th February 2013, 18:55
siucdude911 siucdude911 is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

root@pc:/# ls -la /usr/local/ispconfig/interface/lib/config.inc.php
-rw------- 1 ispconfig ispconfig 6671 Feb 25 12:58 /usr/local/ispconfig/interface/lib/config.inc.php
root@pc:/#
Reply With Quote
  #10  
Old 26th February 2013, 18:57
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,453
Thanks: 813
Thanked 5,222 Times in 4,092 Posts
 
Default

Quote:
Originally Posted by siucdude911 View Post
root@pc:/# ls -la /usr/local/ispconfig/interface/lib/config.inc.php
-rw------- 1 ispconfig ispconfig 6671 Feb 25 12:58 /usr/local/ispconfig/interface/lib/config.inc.php
root@pc:/#
Thats ok.

Please install the following patch update to see if this fixes your issue:

http://www.howtoforge.com/forums/sho...1&postcount=22
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My Centos is terribly slow Galled Server Operation 9 7th December 2010 15:31
Vhosts...conf not synced to changes crypted General 50 24th April 2010 00:54
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19


All times are GMT +2. The time now is 17:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.