Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th February 2013, 20:58
xciso xciso is offline
Member
 
Join Date: Feb 2008
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Default Help with install on OpenVZ vps.

Hello.
I need little help with installation of ispConfig 3 on Debian 6.
I follow this guide: http://www.howtoforge.com/perfect-se...nx-ispconfig-3

But i have a vps, so i think i cant use "quota".

Should i skip step 15:
"apt-get install pure-ftpd-common pure-ftpd-mysql quota quotatool"
and install: "apt-get install pure-ftpd-common pure-ftpd-mysql"

Should i then edit this file: /etc/default/pure-ftpd-common
From: "VIRTUALCHROOT=false"
To: "VIRTUALCHROOT=true"
Like it is written in the guide.

I think i also should skip this in step 15:
fstab changes and quotacheck..

Can someone reguide step 15 to me so it will be more easy to install on OpenVZ vps servers. Or can i just install all this like it was a real server.

One more thing. When i try to do this in step 21: insserv -r apache2
I get this error: insserv: warning: script is corrupt or invalid: /etc/init.d/../rc6.d/S00vzreboot

And then when i try to restart nginx, i get this:
Restarting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()


Please help!
Reply With Quote
Sponsored Links
  #2  
Old 20th February 2013, 23:39
MaddinXx MaddinXx is offline
Senior Member
 
Join Date: Jul 2011
Location: Switzerland
Posts: 200
Thanks: 26
Thanked 64 Times in 47 Posts
Default

Hi

After months of pain I recently was able to get second-level quota (inside container) to work. Based on what distro your HW node runs it's easier or more complicated to archive the goal.

If you have recent versions of the kernel/tools (e.g. when using RHEL based distros with official OpenVZ repos) you can enable 2nd-level quota by:

- installing quota inside the container
- vzctl set <VEID> --quotaugidlimit <USERS/GROUPS> --save

you might need to restart the container afterwards. To check if it worked, make sure you have a line QUOTAUGIDLIMIT="(value from above)" within your /etc/vz/conf/<VEID>.conf file.

Note that the limit should be adjusted from time to time. I've written a small script for that: http://openvz.org/Automatically_setting_quotaugidlimit

If you are on e.g. Debian you should first follow the steps from here: http://wiki.openvz.org/Install_kerne..._on_Debian_6.0 and afterwards the steps above.

Hope this helps
Reply With Quote
  #3  
Old 21st February 2013, 09:44
xciso xciso is offline
Member
 
Join Date: Feb 2008
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks, but i dont really understand
Maybe i will try to follow the guide with apache insted.

I have read that apache is much more ram hungry then nginx, but maybe i can live with that. I have about 500-1000/users that visit sites on the server.

I will most have e-stores at this vps, and i want the site too be fast as possbile. (The stores are in wordpress and Opencart.)

Should i try more with nginx or should i go for apache2?
Thanks!
Reply With Quote
  #4  
Old 21st February 2013, 09:51
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

The quota setup is the same for apache and nginx, so there is no difference in this regard.

Quote:
Should i skip step 15:
No. You just skip the editing of the /etc/fstab file.

Quote:
One more thing. When i try to do this in step 21: insserv -r apache2
I get this error: insserv: warning: script is corrupt or invalid: /etc/init.d/../rc6.d/S00vzreboot
Thats ok and can be ignored.

Quote:
And then when i try to restart nginx, i get this:
Restarting nginx: nginxnginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] bind() to [::]:80 failed (98: Address already in use)
nginx: [emerg] still could not bind()
There is already a software running on post 80. Run:

netstat -tap

to see which software runs there and stop it before you start nginx.

Quote:
Should i try more with nginx or should i go for apache2?
Nginx is fast but its not as easy to use then apache, especially .htaccess files do not work with nginx, so if any of your sites use .htaccess, you will have to write new rules for nginx and insert them in the nginx directives field of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st February 2013, 10:46
xciso xciso is offline
Member
 
Join Date: Feb 2008
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Default

I did netstat -tap
And i get this:
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:imaps                 *:*                     LISTEN      5842/dovecot
tcp        0      0 *:pop3s                 *:*                     LISTEN      5842/dovecot
tcp        0      0 localhost.localdom:9000 *:*                     LISTEN      21515/php-fpm.conf)
tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      19371/amavisd (mast
tcp        0      0 *:mysql                 *:*                     LISTEN      12640/mysqld
tcp        0      0 *:pop3                  *:*                     LISTEN      5842/dovecot
tcp        0      0 *:imap2                 *:*                     LISTEN      5842/dovecot
tcp        0      0 *:ssh                   *:*                     LISTEN      534/sshd
tcp        0      0 *:smtp                  *:*                     LISTEN      6141/master
tcp        0      0 server1.xxx.se:ssh        c-4f66087e-747361:57073 ESTABLISHED 539/0
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      534/sshd
What i can see nothing is using port 80.
Reply With Quote
  #6  
Old 21st February 2013, 11:05
xciso xciso is offline
Member
 
Join Date: Feb 2008
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I have now searched the hole web to make this work...

I found this:http://ibnuyahya.com/nginx-emerg-bin...lready-in-use/

I comment out this line:
Code:
listen [::]:80 default_server
in the file /etc/ngninx/sites-enabled/default

And it worked!!
Can i have it like that or will this be any problem later?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install suphp on centos 6.2 VPS ? botnet Installation/Configuration 1 22nd June 2012 20:43
Cannot install OpenVZ on 10.04 controlmac HOWTO-Related Questions 0 9th February 2012 14:24
cyrus-sasl won't install on my ubuntu9.04 kameelperdza Installation/Configuration 1 13th June 2009 10:28
Help With GUI Menu nightfire Programming/Scripts 3 1st July 2008 15:27
Installation Big issue OpenVZ VPS jbond007 Installation/Configuration 3 7th March 2006 19:40


All times are GMT +2. The time now is 00:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.