Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 20th February 2013, 10:35
Bonzo Bonzo is offline
Junior Member
 
Join Date: Feb 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default SSL, problems with certificate creation and usage

Hi,

I've installed 2 Systems according to this HowTo

http://www.howtoforge.com/installing...th-ispconfig-3

Now I have problems creating SSL certificates, for now I use self-signed but in the future I will use official signed certificate.
I have a domain example com.
If I create a domain example.com with Auto-subdomain No, or www, or a domain www.example.com wit Auto-Subdomain No, I can't use https (after I checked and created the SSL-cert, ispconfig). I get this error.

Code:
Secure Connection Failed

An error occurred during a connection to example.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)
If I create a domain test.example.com, with Auto-Subdomain No, create SSL if works like a charm. Why it's possible to to create test.* but not *. or www. ?

Is it possible to create 2 certificartes, one for one Serve, one for the other?
One (sub)domain pointing to 2 different IP's?
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 16:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.