Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th February 2013, 05:14
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default Email issues

Hey guys,

Again. Thanks for a great product and great help. I know it is all voluntary and it is much appreciated.

My server is really not a money maker but I have put in some long hours on making the 15 or so sites on it work. It's more of a learning experience for me.

My setup is Ubuntu 9.04 and ISPConfig 3 per - http://www.howtoforge.com/perfect-se...04-ispconfig-3

I recently found that I was having email issues. I can't receive any emails to any of the domains that I have setup on my server. I did some research and it seems that this is a semi-common issue. I've searched through my logs to see if I can isolate the issue but don't see anything that stands out to me and most fixes i find either do not apply to my distro or I'm not comfortable trying them. My Linux skills are very limited.

Any advice or help? Also, should I backup and reinstall a newer distro as this one is quite old?

Any and all help is greatly appreciated.

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2013, 00:13
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default Additional info

I don't think I can update/upgrade ClamAV with this distro.
Reply With Quote
  #3  
Old 14th February 2013, 09:36
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,389
Thanks: 833
Thanked 5,486 Times in 4,318 Posts
Default

Quote:
I don't think I can update/upgrade ClamAV with this distro.
This is not the reason for your issue. It does not matter if clamav reports that it is outdated as long as freshclam downloads new updates.

Regarding your original issue, please post the exact error messages from your mail.log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
jopa123 (2nd March 2013)
  #4  
Old 14th February 2013, 14:31
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default Thanks for easing my mind on the ClamAv issue

Thanks, Till

I don't see any error messages in mail.log but 'postqueue -p' does show this type of thing:



11A5C322001 54056 Wed Feb 13 13:49:14 mail@el.linkedin.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

43DEC322006 2515 Wed Feb 13 13:54:09 me@myemailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

45C79322003 21092 Wed Feb 13 13:49:14 returnto@yelp.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

CD7A432200D 20796 Wed Feb 13 19:29:46 3Bz4cURQKCYImuumrkgrkxzy-tuxkvr4muum...s .google.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

CEA8A32200A 6935 Wed Feb 13 14:08:23 bounced@secureserver.net
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

F0A5E322005 24858 Wed Feb 13 13:49:13 update+kjdmjm5vkijm@facebookmail.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

DF42B32200C 2456 Wed Feb 13 17:02:32 me@myemailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

DBACC322010 3492 Thu Feb 14 06:03:55 fZbBvcWzc105@duarib.fr
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

D177E32200E 2119 Wed Feb 13 21:51:47 suhel@yahoo.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
email@mydomain.com

ABAEB322002 2455 Wed Feb 13 13:45:08 me@myemailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

A5A7C10804C 2455 Wed Feb 13 17:09:10 me@myemailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

A5845322009 2453 Wed Feb 13 13:54:11 me@myemailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com

73FAE322008 2455 Wed Feb 13 13:54:10 me@myemailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com



Thanks
Reply With Quote
  #5  
Old 14th February 2013, 15:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,389
Thanks: 833
Thanked 5,486 Times in 4,318 Posts
Default

Run:

ls -la /var/vmail

it should show you a list of directories that have the same names then your email domains. If you see the folders exist, run this command to recursively fix all permissions:

chown -R vmail:vmail /var/vmail
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
jopa123 (2nd March 2013)
  #6  
Old 14th February 2013, 16:22
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default Didn't seem to work

I ran the command and senta test email and this line was added to 'postqeue -p'


AFA03322012 2455 Thu Feb 14 09:08:15 my@emailaddress.com
(temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox.)
shawn@mydomain.com
Reply With Quote
  #7  
Old 15th February 2013, 06:50
florian030 florian030 is offline
Senior Member
 
Join Date: Oct 2012
Posts: 233
Thanks: 8
Thanked 64 Times in 55 Posts
Default

Check the permissions for maildrop. It needs to be setuid root. chmod +s /usr/bin/maildrop.
__________________
regards
Florian

blog.schaal-24.de
Reply With Quote
The Following User Says Thank You to florian030 For This Useful Post:
jopa123 (2nd March 2013)
  #8  
Old 22nd February 2013, 14:06
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by florian030 View Post
Check the permissions for maildrop. It needs to be setuid root. chmod +s /usr/bin/maildrop.
Thanks, Florian030 but that didn't seem to work either.

Here's the new messages in mail.err

Feb 19 10:18:19 server1 last message repeated 3039 times
Feb 19 10:19:20 server1 last message repeated 9393 times
Feb 19 10:20:21 server1 last message repeated 10178 times
Feb 19 10:21:22 server1 last message repeated 9642 times
Feb 19 10:22:23 server1 last message repeated 6266 times
Feb 19 10:23:24 server1 last message repeated 5786 times
Feb 19 10:24:25 server1 last message repeated 6133 times
Feb 19 10:25:26 server1 last message repeated 5442 times
Feb 19 10:26:27 server1 last message repeated 2344 times
Feb 19 10:27:28 server1 last message repeated 539 times
Feb 19 10:27:34 server1 last message repeated 3 times

And here is the mail.log file after i sent a test message today (Feb 22):


Feb 21 06:46:52 server1 postfix/qmgr[14337]: CB590322020: from=<me@localhost.com>, size=5329, nrcpt=1 (queue active)
Feb 21 06:46:52 server1 postfix/qmgr[14337]: 8DF4F10855B: from=<>, size=4573, nrcpt=1 (queue active)
Feb 21 06:46:52 server1 postfix/pipe[10161]: CB590322020: to=<me@mydomain.com>, orig_to=<contact@mydomaincom>, relay=maildrop, delay=315893, delays=315893/0.01/0/0.03, dsn=4.3.0, status=deferred (temporary failure. Command output: ERR: authdaemon: s_connect() failed: Permission denied /usr/bin/maildrop: Unable to open mailbox. )
Feb 21 06:46:52 server1 postfix/smtp[10162]: 8DF4F10855B: to=<myhomeemail@charter.net>, relay=ib1.charter.net[216.33.127.20]:25, delay=231600, delays=231600/0.01/0.15/0, dsn=4.0.0, status=deferred (host ib1.charter.net[216.33.127.20] refused to talk to me: 421 imp05 charter.net ?? charter.net connection refused from [68.113.203.x] E1210)
Feb 21 06:47:06 server1 postfix/smtpd[10186]: connect from localhost.localdomain[127.0.0.1]
Feb 21 06:47:06 server1 postfix/smtpd[10186]: 75A0F32201A: client=localhost.localdomain[127.0.0.1]
Feb 21 06:47:06 server1 postfix/cleanup[10000]: 75A0F32201A: message-id=<20130221124650.A2A61322019@server1.mymaindomai n.com>
Feb 21 06:47:06 server1 postfix/qmgr[14337]: 75A0F32201A: from=<root@server1.mymaildomain.com>, size=1596, nrcpt=1 (queue active)

I'm beginning to think it may be an issue with my internet provider or my DNS zone files at the registrar

As always, any help is appreciated.
Reply With Quote
  #9  
Old 23rd February 2013, 11:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Did you check the permissions of the mailbox and all directories in the path to the mailbox?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
jopa123 (2nd March 2013)
  #10  
Old 27th February 2013, 00:27
jopa123 jopa123 is offline
Senior Member
 
Join Date: Feb 2007
Posts: 140
Thanks: 10
Thanked 1 Time in 1 Post
 
Default

Quote:
Originally Posted by falko View Post
Did you check the permissions of the mailbox and all directories in the path to the mailbox?
Falko,

I'm not sure what you mean by "the mailbox and all other directories in the path of the mail box". Are these "virtual" mailboxes or is there an actual folder/file for each box?

Here is the result of 'ls -la /var/vmail'
total 80
drwxr-xr-x 15 vmail vmail 4096 2013-02-26 17:09 .
drwxr-xr-x 17 root root 4096 2012-10-16 09:22 ..
-rw-r--r-- 1 vmail vmail 220 2009-03-02 08:22 .bash_logout
-rw-r--r-- 1 vmail vmail 3115 2009-03-02 08:22 .bashrc
drwx------ 4 vmail vmail 4096 2012-06-18 11:16 site1.com
drwx------ 3 vmail vmail 4096 2012-06-14 12:26 site2.info
drwx------ 3 vmail vmail 4096 2012-06-14 12:31 site3.info
drwx------ 3 vmail vmail 4096 2012-06-14 12:26 site4.info
drwxr-xr-x 3 vmail vmail 4096 2012-06-14 12:32 site5.info
drwx------ 3 vmail vmail 4096 2012-06-14 12:27 site6.info
drwxr-xr-x 3 vmail vmail 4096 2012-06-14 12:27 site7.info
drwx------ 3 vmail vmail 4096 2012-06-14 12:28 site8.info
drwx------ 3 vmail vmail 4096 2012-06-14 12:29 site9.info
drwx------ 3 vmail vmail 4096 2012-06-14 12:29 site10.info
-rw------- 1 vmail vmail 1454 2013-02-13 17:01 .mailfilter
-rw-r--r-- 1 vmail vmail 1382 2013-02-13 17:01 .mailfilter~
drwxr-xr-x 13 vmail vmail 4096 2013-01-13 12:11 mailfilters
-rw-r--r-- 1 vmail vmail 675 2009-03-02 08:22 .profile
drwx------ 5 vmail vmail 4096 2013-01-02 13:34 site11.com
drwx------ 2 vmail vmail 4096 2012-06-14 12:25 site12.com
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email issues with The Perfect Server - Fedora 12 x86_64 [ISPConfig 3] t-sniper HOWTO-Related Questions 4 19th May 2010 12:44
How to Troubleshoot Email Server Issues ds0101 Installation/Configuration 1 31st July 2009 09:51
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
Email Issues neilsaab Installation/Configuration 4 9th April 2009 18:00
Email issues Digiorb Installation/Configuration 3 9th July 2006 13:31


All times are GMT +2. The time now is 15:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.