Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th February 2013, 03:32
Noah Noah is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default ERROR: Connection dropped by IMAP server.

I followed this great guide: http://www.howtoforge.com/virtual-us...l-ubuntu-10.04

But when trying to connect to squirrel mail, I get the error seen in the title. I have also tried accessing accounts through desktop applications, but no joy (they say to check the username/password).

I have sent myself welcome emails in order to generate the right directories (I've used gmail, mailx and sendmail to do this).

Here is a section of mail.log:

Code:
Feb 12 16:49:35 server1 postfix/tlsmgr[1790]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Feb 12 16:49:43 server1 imapd: test@storbo.net: No such file or directory
Feb 12 16:50:36 server1 postfix/tlsmgr[1799]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Feb 12 16:51:37 server1 postfix/tlsmgr[1842]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Feb 12 16:52:38 server1 postfix/tlsmgr[1849]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Feb 12 16:52:50 server1 imapd: test@storbo.net: No such file or directory
Feb 12 16:53:39 server1 imapd: last message repeated 2 times
Feb 12 16:53:39 server1 postfix/tlsmgr[1865]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Feb 12 16:54:40 server1 postfix/tlsmgr[1872]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Feb 12 16:54:56 server1 amavis[31283]: (31283-01) (!!)WARN: all primary virus scanners failed, considering backups
Feb 12 16:55:08 server1 amavis[31282]: (31282-02) (!!)WARN: all primary virus scanners failed, considering backups
Feb 12 16:55:08 server1 dccproc[1887]: missing message body; fatal error
Feb 12 16:55:15 server1 imapd: test@storbo.net: No such file or directory
Feb 12 16:55:29 server1 imapd: test@storbo.net: No such file or directory
Feb 12 16:55:41 server1 postfix/tlsmgr[1899]: fatal: open database /var/lib/postfix/smtpd_scache.db: Invalid argument
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2013, 07:45
florian030 florian030 is offline
Senior Member
 
Join Date: Oct 2012
Posts: 252
Thanks: 8
Thanked 68 Times in 59 Posts
Default

Try to remove /var/lib/postfix/smtpd_scache.db and reload postfix.Make sure to not run out of disk-space.

Your server is defined as a mailserver (check system/server services)?

BTW: check your amavis-config (all primary virus scanners failed, considering backups)
__________________
regards
Florian

blog.schaal-24.de
Reply With Quote
  #3  
Old 13th February 2013, 08:36
Noah Noah is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by florian030 View Post
Try to remove /var/lib/postfix/smtpd_scache.db and reload postfix.Make sure to not run out of disk-space.

Your server is defined as a mailserver (check system/server services)?

BTW: check your amavis-config (all primary virus scanners failed, considering backups)
Thanks, I read elsewhere to remove smtpd_scache.db and I no longer get that particular error.

I'm not sure what you mean in the second sentence. It's a web server and I am trying to add email services.
Reply With Quote
  #4  
Old 13th February 2013, 21:09
florian030 florian030 is offline
Senior Member
 
Join Date: Oct 2012
Posts: 252
Thanks: 8
Thanked 68 Times in 59 Posts
Default

AFAIK you must enable mail-services for the server so ispconfig can configure the mail-part. Since your system works now, skip it.

You should have a look at "WARN: all primary virus scanners failed, considering backups" - check your amavis-config. You can ignore this warning.
__________________
regards
Florian

blog.schaal-24.de
Reply With Quote
  #5  
Old 14th February 2013, 00:32
Noah Noah is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by florian030 View Post
AFAIK you must enable mail-services for the server so ispconfig can configure the mail-part. Since your system works now, skip it.

You should have a look at "WARN: all primary virus scanners failed, considering backups" - check your amavis-config. You can ignore this warning.
I do not use ISP config. Like I said, I followed this guide: http://www.howtoforge.com/virtual-us...l-ubuntu-10.04

My system does not work now. I just have one less error.
Reply With Quote
  #6  
Old 14th February 2013, 19:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's in your mail log now? Can you post your main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 15th February 2013, 02:10
Noah Noah is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
What's in your mail log now? Can you post your main.cf?
My mail.log looks like this:

Code:
Feb 14 16:02:37 server1 imapd: test@storbo.net: No such file or directory
Feb 14 16:02:38 server1 imapd: Connection, ip=[::ffff:24.87.135.149]
Feb 14 16:02:43 server1 imapd: chdir storbo.net/test/: No such file or directory
Feb 14 16:02:43 server1 imapd: test@storbo.net: No such file or directory
And here is my main.cf

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = server1.storbo.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost, localhost.localdomain
relayhost = 
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_transport = virtual
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
html_directory = /usr/share/doc/postfix/html
virtual_alias_domains = 
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_maildir_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
Reply With Quote
  #8  
Old 15th February 2013, 07:32
florian030 florian030 is offline
Senior Member
 
Join Date: Oct 2012
Posts: 252
Thanks: 8
Thanked 68 Times in 59 Posts
Default

Have you ever sent a mail to test@storbo.ne? Postfix creates the necessary directories when the first mail arrives.
__________________
regards
Florian

blog.schaal-24.de
Reply With Quote
  #9  
Old 15th February 2013, 10:20
Noah Noah is offline
Junior Member
 
Join Date: Feb 2013
Posts: 12
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by florian030 View Post
Have you ever sent a mail to test@storbo.ne? Postfix creates the necessary directories when the first mail arrives.
Like I said in the first post,

Quote:
I have sent myself welcome emails in order to generate the right directories (I've used gmail, mailx and sendmail to do this).
Reply With Quote
  #10  
Old 17th February 2013, 00:20
Desp Desp is offline
Member
 
Join Date: Dec 2008
Location: Sweden
Posts: 37
Thanks: 3
Thanked 5 Times in 3 Posts
Send a message via MSN to Desp Send a message via Yahoo to Desp
 
Default

Hi Noah,
Check http://your-mail-domain.com/src/configtest.php if it gives you any errors.
__________________
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 20:02
Virtual Users+Postfix+Courier+CentOS problem telnet localhost 25 stinson HOWTO-Related Questions 11 5th February 2011 14:57
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 10:32
Can't Ping over VPN RoMiONeT Server Operation 2 4th July 2010 01:19
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 17:59


All times are GMT +2. The time now is 21:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.