Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th February 2013, 22:43
pongo pongo is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default Cant reach ispconfig 3 panel

Hi,

i just set up my server with a fresh installation of Ubuntu 12.10 and want to set up ispconfig 3 and mycloud afterwards. i've followed this guide, but im stuck at point 14.3.1 - PHP-FPM.

when im told to
Code:
cp /usr/local/src/php5-build/php-5.3.18/php.ini-production /opt/php-5.3.18/lib/php.ini
the output says the directory could not be found.
indeed, the directory /opt/php-5.3.18/ is empty.

when i try to access ispconfig via browser, it cant establish a connection.
ive tried hhtp, https, and ports 8080, 81 and 8999.

though i can access the server when typing in my public ip into the browser,

Code:
It works!

This is the default web page for this server.

The web server software is running but no content has been added, yet.
i suggest its running.

you may want to see my netstat-tap output as well:

Code:
Aktive Internetverbindungen (Server und stehende Verbindungen)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 WG-Server:domain        *:*                     LISTEN      1303/dnsmasq    
tcp        0      0 *:ssh                   *:*                     LISTEN      950/sshd        
tcp        0      0 localhost:ipp           *:*                     LISTEN      1110/cupsd      
tcp        0      0 *:smtp                  *:*                     LISTEN      2503/master     
tcp        0      0 *:https                 *:*                     LISTEN      12272/apache2   
tcp        0      0 *:imaps                 *:*                     LISTEN      1069/dovecot    
tcp        0      0 *:pop3s                 *:*                     LISTEN      1069/dovecot    
tcp        0      0 localhost:mysql         *:*                     LISTEN      1117/mysqld     
tcp        0      0 *:pop3                  *:*                     LISTEN      1069/dovecot    
tcp        0      0 *:imap2                 *:*                     LISTEN      1069/dovecot    
tcp        0      0 *:http                  *:*                     LISTEN      12272/apache2   
tcp        0      0 Server.fritz.box:41388  www.howtoforge.com:http VERBUNDEN   2997/firefox    
tcp        0      0 Server.fritz.box:41386  www.howtoforge.com:http VERBUNDEN   2997/firefox    
tcp        0      0 Server.fritz.box:41364  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:56242  bk-in-f138.1e100.n:http VERBUNDEN   2997/firefox    
tcp        1      0 Server.fritz.box:35209  mistletoe.canonica:http CLOSE_WAIT  2940/ubuntu-geoip-p
tcp        0      0 Server.fritz.box:41389  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:32963  static.howtoforge.:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:41385  www.howtoforge.com:http VERBUNDEN   2997/firefox    
tcp        0      0 Server.fritz.box:33698  star-01-02-fra2.fa:http VERBUNDEN   2997/firefox    
tcp        0      0 Server.fritz.box:32938  static.howtoforge.:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:41387  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:41363  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:44954  star-01-02-fra2.f:https VERBUNDEN   2997/firefox    
tcp        0      0 Server.fritz.box:41365  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:41362  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:41351  www.howtoforge.com:http VERBUNDEN   2997/firefox    
tcp        0      0 Server.fritz.box:41361  www.howtoforge.com:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:32939  static.howtoforge.:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:32962  static.howtoforge.:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:32936  static.howtoforge.:http TIME_WAIT   -               
tcp        0      0 Server.fritz.box:32937  static.howtoforge.:http TIME_WAIT   -               
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      950/sshd        
tcp6       0      0 ip6-localhost:ipp       [::]:*                  LISTEN      1110/cupsd      
tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      2503/master     
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      1069/dovecot    
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      1069/dovecot    
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      1069/dovecot    
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      1069/dovecot

please notice that im german and my english might not be perfect

thanks for your time

Last edited by pongo; 9th February 2013 at 22:53.
Reply With Quote
Sponsored Links
  #2  
Old 11th February 2013, 10:26
pongo pongo is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

does nobody have a clue why it wont work? any suggestions are welcome
Reply With Quote
  #3  
Old 11th February 2013, 17:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,732 Times in 2,569 Posts
Default

There's nothing listening on port 8080. Something must have gone wrong while you followed the tutorial.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 11th February 2013, 17:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,249 Times in 4,114 Posts
Default

Did you use the default port (8080) when you installed ispconfig? Please post the output of:

ls -la /etc/apache2/sites-enabled/
ls -la /etc/apache2/sites-available/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 11th February 2013, 18:58
pongo pongo is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

@falko

i dont know, everything seemed to go as planned in the tut, i got no bad responses or unexpected outputs until the described point.
remember, beside the fact i cant reach the control panel, this is my problem:
Code:
root@WG-Server:/usr/local/src/php5-build/php-5.3.18# cp /usr/local/src/php5-build/php-5.3.18/php.ini-production /opt/php-5.3.18/lib/php.ini
cp: reguläre Datei »/opt/php-5.3.18/lib/php.ini“ kann nicht angelegt werden: Datei oder Verzeichnis nicht gefunden
wich says the copy cant be done because the (target?) folder doesnt exist. but i think it already should...


@till
Code:
pongo@WG-Server:~$ ls -la /etc/apache2/sites-enabled/
insgesamt 8
drwxr-xr-x 2 root root 4096 Feb  9 19:04 .
drwxr-xr-x 7 root root 4096 Feb  9 19:03 ..
lrwxrwxrwx 1 root root   26 Feb  9 19:04 000-default -> ../sites-available/default
pongo@WG-Server:~$ ls -la /etc/apache2/sites-available/
insgesamt 20
drwxr-xr-x 2 root root 4096 Feb  9 19:03 .
drwxr-xr-x 7 root root 4096 Feb  9 19:03 ..
-rw-r--r-- 1 root root  692 Jul 16  2012 default
-rw-r--r-- 1 root root 7251 Jul 16  2012 default-ssl

Last edited by pongo; 11th February 2013 at 19:41.
Reply With Quote
  #6  
Old 12th February 2013, 08:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,249 Times in 4,114 Posts
Default

According to the ls output, ispconfig is not installed on the server yet or it has been installed in "expert" mode without installing the interface. Please rerun the ispconfig installer.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pongo (12th February 2013)
  #7  
Old 13th February 2013, 01:24
pongo pongo is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

ok, now i did set up my machine with a fresh installation of ubuntu server 12.10 and followed the instructions step by step. this time, i managed to compile PHP - FPM (didnt use the one with fastcgi) and successfully ran <make> and <make> install.

after that, the tut jumps directly to the ispconfig control panel, so i think it should be installed already, but i still cant manage to access it. what did i miss?

the output of
Code:
ls -la /etc/apache2/sites-enabled/
ls -la /etc/apache2/sites-available/
is still the same.
i did suggest that ispconfig isnt installed yet, but i did not find a command line tutorial to install it. my server now hasnt got a GUI so i'd need to install one first.

any hints?
Reply With Quote
  #8  
Old 13th February 2013, 19:46
dynamind dynamind is offline
Member
 
Join Date: Mar 2011
Location: Mödling bei Wien
Posts: 62
Thanks: 21
Thanked 9 Times in 5 Posts
Send a message via Skype™ to dynamind
Default netstat

Hi,

please post the output of netstat -vatnelp or netstat -vatnelp |grep apache

thanks
Reply With Quote
  #9  
Old 13th February 2013, 22:42
pongo pongo is offline
Junior Member
 
Join Date: Feb 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

sorry but i couldnt manage to print a screenshot without gui (as i said im a bit new to linux)

so heres the output as image - i hope u can see whats important


(https://www.dropbox.com/s/s4z632vrdm...2022.16.50.jpg)


(https://www.dropbox.com/s/j6wwwirze9...2022.16.59.jpg)

Last edited by pongo; 13th February 2013 at 22:44.
Reply With Quote
  #10  
Old 14th February 2013, 09:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,249 Times in 4,114 Posts
 
Default

Quote:
after that, the tut jumps directly to the ispconfig control panel, so i think it should be installed already, but i still cant manage to access it. what did i miss?
No, it is not installed yet. What the tutorial shows you there is what you have to do AFTER you installed ispconfig. Plesae follow all steps of the tutorial until the last line on the last page.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
getting a "forbidden" error 403 when accessing any other page than ISPconfig panel. neumann General 26 14th May 2014 16:16
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 20:03
ISPConfig 3.0.1 released till General 36 29th March 2009 14:30
MyDNS And The MyDNSConfig Control Panel and ISPConfig pg001 General 2 29th July 2008 02:31
Discrepance between ISPConfig panel and database claudioimai Installation/Configuration 1 12th September 2007 17:13


All times are GMT +2. The time now is 20:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.