Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th February 2013, 18:05
jonk jonk is offline
Junior Member
 
Join Date: Feb 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Smtp greeting not received only from gmail

I have postfix running on Ubuntu 12.04 and mails are sent without issues but from past few days have issues only while sending mail to gmail mail servers

Code:
telnet gmail-smtp-in.l.google.com 25
Trying 74.125.141.26..
Connected to gmail-smtp-in.l.google.com.
Escape character is '^]'.
It just hangs there and connection closed by foreign host.

But do not have any issues sending to yahoo, hotmail etc

IP address is not listed in any of the blacklists.

Pls help.
Reply With Quote
Sponsored Links
  #2  
Old 8th February 2013, 00:44
fr0stsp1re fr0stsp1re is offline
Junior Member
 
Join Date: Dec 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Not all SMTP servers will respond with a banner after you telnet into them. It is waiting for you to issue a command and the server is timing out waiting for it. At least that is what it seems like. Issue a HELO or EHLO command and see what happens.
Reply With Quote
  #3  
Old 8th February 2013, 06:11
jonk jonk is offline
Junior Member
 
Join Date: Feb 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Tried it. No luck.
Reply With Quote
  #4  
Old 9th February 2013, 08:21
fr0stsp1re fr0stsp1re is offline
Junior Member
 
Join Date: Dec 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Did you try 465 as well? Try some of the other ports. Is it possible your ISP is filtering port 25?

I just tried telnet on that host you posted and it works fine for me.


Last login: Fri Feb 8 11:31:10 on console
Frosts-Mac-Pro:~ fr0stspire$ telnet
telnet> open
(to) gmail-smtp-in.l.google.com 25
Trying 173.194.79.27...
Connected to gmail-smtp-in.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP f9si43998037paw.256 - gsmtp
EHLO atomiccomputerservice@gmail.com
250-mx.google.com at your service, [50.76.107.157]
250-SIZE 35882577
250-8BITMIME
250-STARTTLS
250 ENHANCEDSTATUSCODES

If you have a firewall switch it off just for testing purposes. Try using telnet from a different host on your network. Seems like the issue is confined to your end. If you are on a DHCP assigned IP for your internet router, see if you can pick up a new ip by going to your mac address clone in your router, pick "use this mac address option" take any two or more numbers or letters and change them. hit save. Power cycle your router and you shall now have a new IP. Test again.

FYI if you are on a DHCP assigned IP on the host you are testing from, you will automatically be blacklisted since DHCP assigned blocks are almost always on blacklists by default. And you cannot be removed from a blacklisted IP block as your ISP is the one who put it there to begin with in most cases. They are trying to stop spam from all angles these days.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail hold in Q fisherofer Installation/Configuration 1 5th February 2012 13:29
amavis rejects all inbound emails aclhkaclhk Installation/Configuration 5 28th February 2010 04:24
Postfix issues NewMee Installation/Configuration 7 20th April 2009 18:52
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
webmail problem mphayesuk General 26 27th April 2006 12:46


All times are GMT +2. The time now is 04:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.