Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2013, 19:25
chrisg chrisg is offline
Junior Member
 
Join Date: Feb 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Postfix - 500 Syntax Error

I have set up a postfix server in front of Exchange.

Things seem to have been running fine then lately I got a report from two different domains that are rejecting emails from us.

This is the message from the bounced emails: host mini.tetherinc.com[67.1xx.1xx.xx] said: 500 Syntax
error, command unrecognized (in reply to DATA command)

So I ssh'd into my postfix server and tried a manual telnet e-mail. This is what happens:

root@antispam:~# telnet 67.1xx.1xx.xx 25
Trying 67.1xx.1xx.xx...
Connected to 67.1xx.1xx.xx.
Escape character is '^]'.
220 mini.tetherinc.com ESMTP Service ready
HELO antispam.appart.com
250 Requested mail action okay, completed
mail from: emailaddress@domain.com
250 Requested mail action okay, completed
rcpt to: emailaddress2@domain.com
250 Requested mail action okay, completed
data
500 Syntax error, command unrecognized


Any ideas on what could possibly be causing this? It is only two domains that have shown this error but they are very important domains that we need to be able to e-mail with no problems. Please help!!
Reply With Quote
Sponsored Links
  #2  
Old 2nd February 2013, 12:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Are there any errors in your mail log (in the /var/log/ directory)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 4th February 2013, 18:39
chrisg chrisg is offline
Junior Member
 
Join Date: Feb 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

There are no errors in the log file when I attempt to send to that domain. It reads as if the e-mail goes thru, then gets rejected and an NDR gets sent back containing the error 500 Syntax error, command unrecognized (in reply to DATA command)
Reply With Quote
  #4  
Old 5th February 2013, 20:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Maybe those external servers blacklisted your mail server. It is possible that they were configured to reply with a (misleading) 500 error.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 5th February 2013, 20:24
chrisg chrisg is offline
Junior Member
 
Join Date: Feb 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I have solved the issue for one of the domains. It was un-related. After getting more information from the user I found out she was using an accounting program to send the emails therefore relaying which the other server denied.

I still am having an issue with the server giving me the syntax error.

This is a client who emailed us asking for a quote and then we couldn't respond so I don't think we were blacklisted as it was not a domain we were emailing previously. Also, our domain doesn't appear on any of the blacklists on the internet when doing a quick search.
Reply With Quote
Reply

Bookmarks

Tags
550, bounce, error, postfix, smtp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 01:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.