Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd February 2013, 06:04
sparktino sparktino is offline
Junior Member
 
Join Date: Feb 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig not listening

Hello after running the install script ISPConfig is not listening on port 8080.
The script ran successfully eventhough I noticed mysql start and stop was missing from the steps.
=============================
Configuring Jailkit
Configuring Dovecot
Configuring Spamassassin
Configuring Amavisd
Configuring Getmail
Configuring Pureftpd
Configuring BIND
Configuring nginx
Configuring Vlogger
Configuring Apps vhost
Configuring Bastille Firewall

Installing ISPConfig
ISPConfig Port [8080]:

Configuring DBServer
Installing ISPConfig crontab
Restarting services ...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [ OK ]
Starting saslauthd: [ OK ]
Stopping Dovecot Imap: [ OK ]
If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
This message goes away after the first successful login.
Starting Dovecot Imap: [ OK ]
Reload service php-fpm done
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful
Reloading nginx: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Installation completed.
===========================================

Can anybody please tell what is wrong here.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 2nd February 2013, 13:55
sparktino sparktino is offline
Junior Member
 
Join Date: Feb 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Somebody please help me to find a solution

I really stuck at this point. Not sure what to do

Your help will be really appreciated
Reply With Quote
  #3  
Old 4th February 2013, 12:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,388 Times in 4,233 Posts
Default

Quote:
The script ran successfully eventhough I noticed mysql start and stop was missing from the steps.
Thats not missing. Mysql dos not have to be restarted.

Quote:
Can anybody please tell what is wrong here.
Please post the output of:

netstat -tap

and

iptables-L
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 4th February 2013, 15:50
sparktino sparktino is offline
Junior Member
 
Join Date: Feb 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thank you Till for responding to this thread.

I reinstalled it after disabling the firewall. But the same result. So currently there are no firewall rules present in the server.
========

# iptables -L
Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

========

Here is the output of netstat command. ISPconfig is not listening on port 8080

=======
# netstat -tlpn
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:993 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 0.0.0.0:995 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 127.0.0.1:199 0.0.0.0:* LISTEN 2059/snmpd
tcp 0 0 127.0.0.1:9000 0.0.0.0:* LISTEN 4875/php-fpm
tcp 0 0 127.0.0.1:10025 0.0.0.0:* LISTEN 4834/master
tcp 0 0 0.0.0.0:3306 0.0.0.0:* LISTEN 4059/mysqld
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 0.0.0.0:9102 0.0.0.0:* LISTEN 2715/bacula-fd
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN 4863/dovecot
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1900/portmap
tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN 4982/nginx
tcp 0 0 10.8.72.1:53 0.0.0.0:* LISTEN 4961/named
tcp 0 0 xxx.xxx.xx.xxx:53 0.0.0.0:* LISTEN 4961/named
tcp 0 0 127.0.0.1:53 0.0.0.0:* LISTEN 4961/named
tcp 0 0 0.0.0.0:21 0.0.0.0:* LISTEN 4909/pure-ftpd (SER
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 2122/sshd
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 2130/cupsd
tcp 0 0 127.0.0.1:63000 0.0.0.0:* LISTEN 1743/vmad-bin
tcp 0 0 127.0.0.1:953 0.0.0.0:* LISTEN 4961/named
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 4834/master
tcp 0 0 :::993 :::* LISTEN 4863/dovecot
tcp 0 0 :::995 :::* LISTEN 4863/dovecot
tcp 0 0 :::110 :::* LISTEN 4863/dovecot
tcp 0 0 :::143 :::* LISTEN 4863/dovecot
tcp 0 0 :::53 :::* LISTEN 4961/named
tcp 0 0 :::21 :::* LISTEN 4909/pure-ftpd (SER
tcp 0 0 :::22 :::* LISTEN 2122/sshd
tcp 0 0 ::1:953 :::* LISTEN 4961/named
===========
Reply With Quote
  #5  
Old 4th February 2013, 19:56
sparktino sparktino is offline
Junior Member
 
Join Date: Feb 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried the installation in a fresh server. After installing all the necessarry services I executed the installation script. This time it showed mysql start/stop in the output. But ISPconfig did not get started.

=========
Configuring DBServer
Installing ISPConfig crontab
no crontab for root
no crontab for getmail
Restarting services ...
Stopping mysqld: [ OK ]
Starting mysqld: [ OK ]
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [FAILED]
Starting saslauthd: [ OK ]
Shutting down Mail Virus Scanner (amavisd): [FAILED]
Starting Mail Virus Scanner (amavisd): [ OK ]
Stopping Clam AntiVirus Daemon: [ OK ]
Starting Clam AntiVirus Daemon: [ OK ]
Stopping Dovecot Imap: [ OK ]
If you have trouble with authentication failures,
enable auth_debug setting. See http://wiki.dovecot.org/WhyDoesItNotWork
This message goes away after the first successful login.
Starting Dovecot Imap: [ OK ]
nginx: the configuration file /usr/local/nginx/conf/nginx.conf syntax is ok
nginx: configuration file /usr/local/nginx/conf/nginx.conf test is successful
Reloading nginx: [ OK ]
Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Installation completed.
=======

Is there any thing wrong with the installation script?.
I am running this on a Centos 5.5 64-bit machine.
Reply With Quote
  #6  
Old 5th February 2013, 20:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Have you tried to restart Apache?

Code:
/etc/init.d/httpd restart
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 5th February 2013, 20:25
sparktino sparktino is offline
Junior Member
 
Join Date: Feb 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,

As you can see from the installation output posted in my previous reply I am using nginx instead of apache.

Thanks
Reply With Quote
  #8  
Old 6th February 2013, 13:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Which distribution do you use? What's your nginx version? Have you tried to restart nginx?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 6th February 2013, 14:24
sparktino sparktino is offline
Junior Member
 
Join Date: Feb 2013
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Falko,

I am using Centos 5.5 64-bit. I tried to install ispconfig in two servers. In one server I used nginx version nginx/1.0.3 and in other nginx/1.2.1.

Yes, I restarted nginx many times and that did not make any difference.
Is there any startup script for ispconfig that gets installed during the installation? . I can't see one in /etc/init.d/

Thanks
Reply With Quote
  #10  
Old 9th February 2013, 08:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

How did you install nginx? I think the nginx version coming with CentOS 5.5 is much older then what you use, so I guess you installed nginx manually somehow.

Quote:
Is there any startup script for ispconfig that gets installed during the installation? . I can't see one in /etc/init.d/
No, ISPConfig 3 has no startup script.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hosting multiple websites and webmail dmwcool Installation/Configuration 8 30th March 2010 03:15
Ftp problems timeout reny2000 General 6 23rd December 2009 11:09
Troubleshooting ispconfig not listening on port 8080 isn Installation/Configuration 1 20th December 2009 01:00
ISPConfig 2.3.2-dev released till General 9 4th June 2007 10:46
Virtual Users And Domains With Postfix, Courier And Mysql....help needed MrMattles HOWTO-Related Questions 9 13th February 2006 09:50


All times are GMT +2. The time now is 18:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.