Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th January 2013, 18:12
primal23 primal23 is offline
Member
 
Join Date: Aug 2009
Posts: 78
Thanks: 13
Thanked 1 Time in 1 Post
Default /boot not ready after syncing RAID 1 w/ virgin drive

I am running Ubuntu 10.04, and used the How-to-setup RAID 1 on running system including GRUB2.

So I was planning on doing the upgrade to 12.04, and wanted to have a backup in case something goes haywire. So I took out one hard drive, put in a blank, and booted Ubuntu, and synced the raid, and installed GRUB.

Everything seemed fine, so I removed both drives and put in a blank as secondary, and the one I just synced into the primary, boot the system, and it takes me to the grub rescue menu.

So shutting down the system and putting back the original primary back in, the system boots, but the Ubuntu gives me a message,

/boot in not not ready or not installed

I skip that, get into Ubuntu, and md0 is not active. When I tried to update-grub, or os-prober I get this error:

ERROR: isw: wrong number of devices in RAID set "isw_dfichbebdi_Volume0:1" [1/2] on /dev/sda

Grub seems to have an older linux kernel it's "stuck" on, and I can't find a way to change it to the one currently used by Ubuntu.

Any help would be appreciated! Thanks!
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Companion Script #2 for The Perfect Server - Fedora 13 x86_64 [ISPConfig 3]" MrCompTech Tips/Tricks/Mods 0 10th July 2010 05:11
Adding non-RAID backup disk to system with RAID 1... BorderAmigos Installation/Configuration 1 20th February 2010 20:50
Can all the installation and configuration be automated (Kickstart) gabby Installation/Configuration 0 30th January 2010 19:47
Syncing two servers bagpiperdude90 Technical 4 18th March 2007 19:35
SATA Software RAID 1 on Linux mphayesuk Installation/Configuration 2 21st February 2006 11:31


All times are GMT +2. The time now is 16:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.