Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th January 2013, 03:14
suffolk suffolk is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default The Perfect Server - CentOS 6.3 x86_64 (Ap2, Dcot, ISPConfig 3)

Firstly i hope this is in correct area

Hi all
i discovered this howtoforge brill thought i would have a go

and i got stuck.

i followed page by page and come unstuck on page 4

www. howtoforge.com/perfect-server-centos-6.3-x86_64-apache2-dovecot-ispconfig-3

i have 4 errors and thought i should stop installing as per pages

here is list
----------------------------------
pasted from terminal


vi /etc/httpd/conf.d/phpmyadmin.conf

#
# Web application to manage MySQL
#

#<Directory "/usr/share/phpmyadmin">
# Order Deny,Allow
# Deny from all
# Allow from 127.0.0.1
#</Directory>

Alias /phpmyadmin /usr/share/phpmyadmin
Alias /phpMyAdmin /usr/share/phpmyadmin
Alias /mysqladmin /usr/share/phpmyadmin
Next we change the authentication in phpMyAdmin from cookie to http:

vi /usr/share/phpmyadmin/config.inc.php

[...]
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'http';
[...]
Then we create the system startup links for Apache and start it:

chkconfig --levels 235 httpd on
/etc/init.d/httpd start


================================================== ========================================



[root@Centos /]# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error

on line 1 of /etc/httpd/conf.d/suphp.conf: LoadModule takes two arguments, a module name and

the name of a shared object file to load it from
[FAILED]


================================================== ========================================


[root@Centos /]# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error

on line 1 of /etc/httpd/conf.d/suphp.conf: LoadModule takes two arguments, a module name and

the name of a shared object file to load it from
[FAILED]


================================================== ====================================
[root@Centos ~]# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error

on line 1 of /etc/httpd/conf.d/suphp.conf: LoadModule takes two arguments, a module name and

the name of a shared object file to load it from
[FAILED]
[root@Centos ~]#


================================================== =====================================
nstalled:
mod_python.i686 0:3.3.1-15.el6

Complete!
[root@Centos ~]# /etc/init.d/httpd restart
Stopping httpd: [FAILED]
Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error

on line 1 of /etc/httpd/conf.d/suphp.conf: LoadModule takes two arguments, a module name and

the name of a shared object file to load it from
[FAILED]

================================================== ===================================
i have reached 15.3 WebDAV nothing done
thought i better stop and seek help
but open to offers of remote help if all fails

regards john
Reply With Quote
Sponsored Links
  #2  
Old 29th January 2013, 18:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in line 221 of /etc/httpd/conf/httpd.conf and in line 1 of /etc/httpd/conf.d/suphp.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th January 2013, 20:26
suffolk suffolk is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default re ispconf 3

Hi thanks for reply
info requested ..
line 221 include conf.d/*.conf

line 1 loadmodule suphp_modules/mod_suphp.so



--------------------------
i went over it again checking all i did and ive got this message

fsck ext4 no such file or directory
superblock could not read or does not describe a correct ext2 file system




think its crashed
i am using a ssd 60gb

Last edited by suffolk; 29th January 2013 at 20:43.
Reply With Quote
  #4  
Old 30th January 2013, 02:59
suffolk suffolk is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default Re centos / ispconf

Hi it crashed some how
so i have reinstalled it as per The Perfect Server - CentOS 6.0 x86_64 [ISPConfig 3]

ive got to quota section and got following


I added the following to fstab
,usrjquota=aquota.user,grpjquota=aquota.group,jqfm t=vfsv0 1 1

but i get errors below

[root@Centos tmp]# mount -o remount /
[root@Centos tmp]# quotacheck -avugm
quotacheck: Scanning /dev/mapper/vg_centos-lv_root [/] done
quotacheck: Cannot stat old user quota file: No such file or directory
quotacheck: Cannot stat old group quota file: No such file or directory
quotacheck: Cannot stat old user quota file: No such file or directory
quotacheck: Cannot stat old group quota file: No such file or directory
quotacheck: Checked 13630 directories and 112865 files
quotacheck: Old file not found.
quotacheck: Old file not found.
[root@Centos tmp]#


im unable to edit even after reading fstab help

paused installation now till its resolved

john
Reply With Quote
  #5  
Old 30th January 2013, 08:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

The quota errors are ok, so othing to worry about. Just proceedwith the next command. As you turned on quota for the first time, the old files can not be found as they dont exist yet.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
suffolk (30th January 2013)
  #6  
Old 30th January 2013, 19:21
suffolk suffolk is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Ive gor futher this time relised i was i686

but stuck here now

[root@Centos /]# /etc/init.d/courier-imap start
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
[root@Centos /]# yum install postfix
Loaded plugins: fastestmirror, priorities, refresh-packagekit
Loading mirror speeds from cached hostfile
* base: mirror01.th.ifl.net
* epel: ftp.heanet.ie
* extras: mirror.mhd.uk.as44574.net
* updates: mirror01.th.ifl.net
69 packages excluded due to repository priority protections
Setting up Install Process
Package 2ostfix-2.6.6-2.2.el6_1.i686 already installed and latest version
Nothing to do
[root@Centos /]# chkconfig --levels 235 mysqld on
[root@Centos /]# /etc/init.d/mysqld start
Starting mysqld: [ OK ]
[root@Centos /]# chkconfig --levels 235 sendmail off
error reading information on service sendmail: No such file or directory
Reply With Quote
  #7  
Old 30th January 2013, 19:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,982 Times in 3,903 Posts
Default

The command disables sendmail to ensure that it is not running as we use postfix for this setup. If sendmail does not exist, then thats fine as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 30th January 2013, 21:19
suffolk suffolk is offline
Junior Member
 
Join Date: Jan 2013
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

im unable to connect myphpadmin error message

Forbidden

You don't have permission to access /phpmyadmin/ on this server.

Apache/2.2.15 (CentOS) Server at 192.168.1.1** Port 80
================================================== ==
this is what i did previous




vi /etc/httpd/conf.d/phpmyadmin.conf

i just added the following line

Alias /mysqladmin /usr/share/phpmyadmin <---


# phpMyAdmin - Web based MySQL browser written in php
#
# Allows only localhost by default
#
# But allowing phpMyAdmin to anyone other than localhost should be considered
# dangerous unless properly secured by SSL

Alias /phpMyAdmin /usr/share/phpMyAdmin
Alias /phpmyadmin /usr/share/phpMyAdmin
Alias /mysqladmin /usr/share/phpmyadmin <---

<Directory /usr/share/phpMyAdmin/>
<IfModule mod_authz_core.c>
# Apache 2.4
<RequireAny>
Require ip 127.0.0.1
Require ip ::1
</RequireAny>
</IfModule>
<IfModule !mod_authz_core.c>
# Apache 2.2
Order Deny,Allow
Deny from All
Allow from 127.0.0.1
Allow from ::1
</IfModule>
</Directory>

<Directory /usr/share/phpMyAdmin/setup/>
<IfModule mod_authz_core.c>
# Apache 2.4
<RequireAny>
Require ip 127.0.0.1
Require ip ::1
</RequireAny>
</IfModule>
<IfModule !mod_authz_core.c>
# Apache 2.2
Order Deny,Allow
Deny from All
Allow from 127.0.0.1
Allow from ::1
</IfModule>
</Directory>

# These directories do not require access over HTTP - taken from the original
# phpMyAdmin upstream tarball
#
<Directory /usr/share/phpMyAdmin/libraries/>
Order Deny,Allow
Deny from All
Allow from None
</Directory>

<Directory /usr/share/phpMyAdmin/setup/lib/>
Order Deny,Allow
Deny from All
Allow from None
</Directory>

<Directory /usr/share/phpMyAdmin/setup/frames/>
Order Deny,Allow
Deny from All
Allow from None
</Directory>

# This configuration prevents mod_security at phpMyAdmin directories from
# filtering SQL etc. This may break your mod_security implementation.
#
#<IfModule mod_security.c>
# <Directory /usr/share/phpMyAdmin/>
# SecRuleInheritance Off
# </Directory>
#</IfModule>

==================================================

Next we change the authentication in phpMyAdmin from cookie to http:



vi /usr/share/phpmyadmin/config.inc.php

as there was no config.inc.php i made 1 and pasted lines below and rebooted (config.sample.inc.php is still there)

[...]
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'http';
[...]
=============================================

Then we create the system startup links for Apache and start it:

chkconfig --levels 235 httpd on
/etc/init.d/httpd start

Now you can direct your browser to server1.example.com/phpmyadmin or 192.168.0.100/phpmyadmin and log in with the user name root and your new root MySQL password.

Apache2 test page does show with just ip

john

Last edited by suffolk; 30th January 2013 at 21:31.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 18:17
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Howtoforge the perfect Server(links) rini90 Installation/Configuration 0 14th December 2008 10:58


All times are GMT +2. The time now is 21:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.