Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th October 2012, 14:01
todx todx is offline
Member
 
Join Date: Apr 2012
Posts: 77
Thanks: 33
Thanked 6 Times in 5 Posts
Default [Solved] Poor performance on RoundCube using ISPConfig 3

I've been using ISPConfig 3 for a year or so. I've got a bunch of email accounts setup, each one has 5000+ emails in it. Whenever I go to RoundCube and click on Inbox it can take up to 2-3 seconds for the list of emails to load (locally not over the internet). This server is running on high-end components. Also not on SCSI but SSD - so disk and internet load shouldn't be a problem.

Now my question. Can this be result of poor server configuration? Or is there a problem with RoundCube? What should I do? Am I using the wrong email client?

Last edited by todx; 17th October 2012 at 17:11.
Reply With Quote
Sponsored Links
  #2  
Old 17th October 2012, 14:23
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,266 Times in 4,129 Posts
Default

This can be caused by many different things, the default configuration of the perfects etup is very fast, but there might be changes in your server configuration that slow the system down or high load etc. So to find the bottleneck, you have to check services step by step.

As a first step, i would install another webmail client beside oundcube e.g. squirrelmail. Squirremail is quite fast, so if you dont get the same delay in squirrelmail that you get in roundcube, you have narrowed down the issue to roundcube. If you experience the same delays, then it might be related to the imap server configuration or harddisk performance / load of the server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th October 2012, 15:09
todx todx is offline
Member
 
Join Date: Apr 2012
Posts: 77
Thanks: 33
Thanked 6 Times in 5 Posts
Default

How can I check disk load of my server? What could be wrong with IMAP server (example for this case)?
Reply With Quote
  #4  
Old 17th October 2012, 15:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,266 Times in 4,129 Posts
Default

You installed squirrelmail and it reacts fast?

The other options are a wide field as config files for sevices contain hindreds of options, so please check the webmail client first.

You can see the server load with top or uptime command, If it is high (permamently > 10) then it can be related to your problem and in this case it might make sense to install io load monitoring software.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th October 2012, 17:09
todx todx is offline
Member
 
Join Date: Apr 2012
Posts: 77
Thanks: 33
Thanked 6 Times in 5 Posts
Default

Well basically what I did is, like you said it could be the mail client, instead of installing squirrelmail client I googled a bit for RoundCube performance and found this:
http://trac.roundcube.net/wiki/Howto_Performance
from here, I checked a few settings, changed them properly and now my list of mails loads very quickly.

What I changed was:
'imap_cache' => 'db' # how/where and if to cache imap
'messages_cache' => true # caches the mesages into mysql which I found out its acctually faster than reading directly from mail directory
'imap_auth_type' => 'LOGIN' # which is my imap auth type, this setting skips RoundCubes one step towards authentication
'smtp_auth_type' => 'LOGIN' # so does this one

So yeah, basically this worked for me. Thanks Till.

By the way, I checked my server load and it was around 1.0 which is why I focused on the mail client.
Reply With Quote
The Following User Says Thank You to todx For This Useful Post:
webguyz (28th October 2012)
  #6  
Old 24th January 2013, 11:01
Drakon Drakon is offline
Junior Member
 
Join Date: Jan 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up Thanks

Thanks for your comments! Works for me too!

I've changed the same:
Code:
$rcmail_config['imap_cache'] = 'db';
$rcmail_config['messages_cache'] = true;
and the performance has improved when opening folders with thousand of e-mails (with Roundcube 0.8.4 + Postfix + MySQL + Courier IMAP).

Thanks!
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, poor performance, roundcube

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
All files gone after changing quota to 0 spynode General 17 19th January 2012 14:41
ISPConfig reports SMTP-server down, with Roundcube installed toffie Installation/Configuration 2 1st December 2011 10:55
Ubuntu 11.10, ISPConfig 3.0.4.1 needs some nginx.conf tweaks after following guide. talkingnews Installation/Configuration 10 28th November 2011 21:55
Migrating to ISPConfig - step by step (postfixadmin + Anti-Spam-Solution + roundcube) osterhase Installation/Configuration 2 30th July 2011 20:10
security patch for RoundCube 0.2 Beta for ISPCOnfig 2 Hans General 2 3rd January 2009 10:12


All times are GMT +2. The time now is 12:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.