Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th January 2013, 02:21
thedoc351 thedoc351 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 20
Thanks: 0
Thanked 2 Times in 2 Posts
Default Apache failure to start due to SSL

I have a site that demands a SSL cert. The cert expired so I used your guide to generate a new certificate then followed the guide to use RapidSSL. Now when I try to start apache I get domain.bundle does not exist or is empty. So after getting that I copied the new certs into a file called domain.bundle and tried again to start apache. Now I see this: Restarting web server: apache2 failed! Anyone's help is appreciated. I really need to get this site up and running again ASAP.
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2013, 03:48
thedoc351 thedoc351 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 20
Thanks: 0
Thanked 2 Times in 2 Posts
Default more information

I would like to add that this is ispconfig 3.4. The original certificate was a free one from comodo that was used. I did delete the certificate in ispconfig ssl directive and that is when this problem started.
Reply With Quote
  #3  
Old 18th January 2013, 11:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you replace Comodo's bundle certificate with the one from RapidSSL?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 18th January 2013, 11:59
thedoc351 thedoc351 is offline
Junior Member
 
Join Date: Sep 2010
Posts: 20
Thanks: 0
Thanked 2 Times in 2 Posts
Default

Yes I followed your tutorial to the letter. Could you tell me how I might generate new self signed so that apache will start and I can start over?

okay here is what I have done so far. I disabled ssl and apache started. If I enable ssl apache fails to start. I assume this is from an invalid cert. What is the procedure to create new certs and enable ssl once more? This is a debian Lenny install of ispconfig 3.4

Last edited by thedoc351; 19th January 2013 at 11:57. Reason: revised
Reply With Quote
  #5  
Old 21st January 2013, 19:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Delete the cert in ISPConfig and create a new one.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL Certificate Error - Apache does not start snowfly Installation/Configuration 9 23rd April 2014 04:01
The Perfect Server - Ubuntu 10.10 [ISPConfig 3] artifact66 Installation/Configuration 3 14th March 2011 13:06
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
Monit on Debian Hans Tips/Tricks/Mods 2 6th October 2008 13:53
CENTOS 5 Ping Problem gAnDo Server Operation 11 28th March 2008 20:58


All times are GMT +2. The time now is 20:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.