Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th January 2013, 10:40
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
Default Turnkey & ISPConfig

I installed ISPConfig on a Turnkey OpenVZ template and got it work but for some reason the System State show Web-Server as Offline.

Where can I set that so that it will show correct system state for Apache?
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
Sponsored Links
  #2  
Old 16th January 2013, 10:44
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,572
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Ensure that apache listens on localhost as well.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 16th January 2013, 12:37
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
Default

The only difference I see in the /etc/apache2/ports.conf is that ISPConfig normally has these...

Quote:
NameVirtualHost *:80
Listen 80
And the Turnkey has only
Quote:
Listen 80
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
  #4  
Old 16th January 2013, 15:59
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,572
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Are you able to accessapaxhe at localhost e.g. with:

telnet localhost 80
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th January 2013, 07:30
SamTzu SamTzu is offline
HowtoForge Supporter
 
Join Date: Apr 2007
Location: Helsinki
Posts: 424
Thanks: 33
Thanked 50 Times in 35 Posts
Send a message via Skype™ to SamTzu
Default

Yes. I can telnet to localhost on port 80 (and to 127.0.0.1).
__________________

Sami Mattila
Internet-Content

Telephone:
00358942833310
Email: firstname.lastname@internet-content.org
Shop: http://shop.internet-content.net
Site: http://www.internet-content.net
Blog: http://www.internet-content.net/en/blog
FB: https://www.facebook.com/internetcontent

Reply With Quote
  #6  
Old 17th January 2013, 10:24
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,572
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Thats what ispconfig is doing to check if the server is online. Maybe turnkey linux has disabled any php options then or a similar problem.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 18th January 2013, 10:02
rogershado rogershado is offline
Junior Member
 
Join Date: Jan 2013
Posts: 16
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by SamTzu View Post
The only difference I see in the /etc/apache2/ports.conf is that ISPConfig normally has these...



And the Turnkey has only
which Turnkey are you using because in mine after install off ispconfig it look like this

Quote:
# If you just change the port or add more ports here, you will likely also
# have to change the VirtualHost statement in
# /etc/apache2/sites-enabled/000-default
# This is also true if you have upgraded from before 2.2.9-3 (i.e. from
# Debian etch). See /usr/share/doc/apache2.2-common/NEWS.Debian.gz and
# README.Debian.gz

NameVirtualHost *:80
Listen 80

<IfModule mod_ssl.c>
# If you add NameVirtualHost *:443 here, you will also have to change
# the VirtualHost statement in /etc/apache2/sites-available/default-ssl
# to <VirtualHost *:443>
# Server Name Indication for SSL named virtual hosts is currently not
# supported by MSIE on Windows XP.
Listen 443
</IfModule>

<IfModule mod_gnutls.c>
Listen 443
</IfModule>
have 5 running
And all work perfect

both on stable and 3.0.5 rc

Last edited by rogershado; 18th January 2013 at 10:07.
Reply With Quote
Reply

Bookmarks

Tags
ispconfig 3, turkey

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 20:03
around 80 sleeping connections created by ISPConfig bkilinc General 2 1st October 2012 16:12
Control Panel - E-mail Tab is empty domi-nik General 15 14th April 2011 18:17
chroot SSH IspConfig2 kextra1 General 4 20th January 2011 18:41
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 17:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.