Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 10th January 2013, 17:08
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 388
Thanks: 28
Thanked 58 Times in 50 Posts
Default SPAM scores via ISPconfig + AMaViS are much lower than SpamAssassin on command line

I have posted the details of my issue to the SpamAssassin User Group:

http://www.gossamer-threads.com/list...n/users/176514

In short, email messages are coming through with very low X-Spam-Score header values.

I dumped a few sample emails and fed them to "spamassassin" on the command line and the scores were much, much higher; they seemed "correct".

Folks on the SA User Group suggested that I check whether network tests are being run when SA is called via AMaViS.

The problem is that I don't know how to call AMaViS directly, e.g., from the command line, in a way that simulates how the message will be processed in a real situation.

I did check my AMAViS configuration, and on the surface, network tests appear to be enabled:

Code:
# grep -ir sa_local_tests_only /etc/amavis
/etc/amavis/conf.d/20-debian_defaults:$sa_local_tests_only = 0;    # only tests which do not require internet access?
Does ISPConfig somehow disable network tests by some other means?

I did have a look at http://www.ijs.si/software/amavisd/#faq-spam and walk through the items in the section entitled SpamAssassin returns different score or null score or triggers different set of SA rules when called from amavisd-new, as compared to the command-line utility spamassassin on the same message. What is wrong?

In my tests, I am calling "spamassassin" from the "amavis" user account, amavis is not running in a chrooted environment, and nothing else that is mentioned stands-out. My Bayes database looks fine, and I don't think it's a factor here.

I realize that ISPConfig allows for SPAM policies to be applied at the domain and/or mailbox level, so, ideally, I'd like to be able to "simulate" the process by which email messages for a specific domain/mailbox will be scored when fed to SA via AMaViS.

Thanks in advance!

Last edited by cbj4074; 10th January 2013 at 17:15.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[ask] Amavis BLOCK spam, not forward to receive dedeon Server Operation 1 17th April 2011 15:58
[The Perfect Spamsnake Ubuntu 10.10] - No mail relay, just errors. itsnedkeren HOWTO-Related Questions 2 20th February 2011 10:45
Amavis SQL-Problem / ISPConfig writes empty fields instead of NULL hli General 4 18th February 2011 00:00
How to kill spam when spamassassin marks it spam kpimichael Suggest HOWTO 15 6th August 2007 16:44
config spamassassin hotchilli Server Operation 1 8th July 2006 12:03


All times are GMT +2. The time now is 03:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.