Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th January 2013, 22:01
cbj4074 cbj4074 is offline
Senior Member
 
Join Date: Nov 2010
Posts: 392
Thanks: 29
Thanked 58 Times in 50 Posts
Default SSL certificate components are not renamed when website domain is changed

I noticed that when I change the domain name that is associated with a given website (an excellent and very powerful feature of ISPConfig), using the drop-down menu in the interface, the certificate component file names in /var/www/example.com/ssl are not updated accordingly.

This seems to be an undesirable behavior for many reasons, not least of which is that Apache will fail to start if SSL is enabled, the website's domain name is changed, and Apache is restarted. Presumably, Apache will expect to find the files at /var/www/example.com/ssl/example.com.*, when they may in fact exist at /var/www/example2.com/ssl/example.com.*.

One solution to this problem, provided that ISPConfig does not already handle this scenario gracefully (I have not tested it with the SSL checkbox enabled), is to change the SSL certificate component file names such that they reflect the website ID instead of the domain name. This would enable the user to change the domain name without causing problems for Apache or the SSL certificate (beyond the expected "domain name mismatch").

Thanks for any thoughts on this.
Reply With Quote
Sponsored Links
  #2  
Old 5th January 2013, 12:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

I think this is already resolved in 3.0.5.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
apache, certificate, ssl, symlink

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL certificate chief Installation/Configuration 13 28th December 2012 16:46
SSL not working ITG Installation/Configuration 4 9th December 2012 06:15
Postfix not forwarding for some domains flappy Installation/Configuration 3 21st November 2010 18:57
Issues securing Webmail with SSL Certificate Robeast Installation/Configuration 10 31st January 2008 02:05
SSL related problems senzapaura Installation/Configuration 45 25th March 2006 15:15


All times are GMT +2. The time now is 20:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.