Prev Previous Post   Next Post Next
  #1  
Old 4th January 2013, 18:22
ItsDom ItsDom is offline
Member
 
Join Date: Dec 2012
Posts: 41
Thanks: 2
Thanked 5 Times in 5 Posts
Default Debugging nginx directives

Hi,

I'm trying to get cakephp working with ISPConfig3 and nginx (loosely following http://www.howtoforge.com/perfect-se...ot-ispconfig-3)

I have the server setup fine (I can run phpinfo() and other snippets of php fine) but I can't get cake working. I think it's because cake out of the box relies on mod-rewrite, but by default it should still work out of the box, just look ugly. But it doesn't work at all, I just get 404's, I'm guessing because it's redirecting me somewhere the doesn't exist.

But when I add nginx directives through the ISPC control panel, sometimes they don't get applied fully, but a mydomain.vhost.err shows up in /etc/nginx/sites-available. But there's absolutely no indication or documentation or log or anything anywhere I can find that explains this - am I missing something here?

Is there a way to debug site-specific nginx directives? And also, might it be possible that future version of ISPC indicate there has been a problem applying directives in the control panel, rather than having to manually check /etc/nginx/sites-available?

Thanks,

Dom.

EDIT: I'm running ISPConfig 3.0.5RC1, nginx 1.3.7 and I've tried cakephp 2.2.5 and 2.3.0RC1

Last edited by ItsDom; 4th January 2013 at 18:25.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 20:02
local ip:8080 just downloads a file called download or index.php dr_patso Installation/Configuration 5 20th September 2011 21:54
SSL don't work please help me walner8080 Installation/Configuration 8 26th September 2010 13:07
FTP cannot open remote folder!?! andysm849 Server Operation 23 17th October 2008 00:34
Having Problems with KWiFiManager sbovisjb1 Installation/Configuration 7 17th April 2006 23:53


All times are GMT +2. The time now is 13:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.