Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd January 2013, 17:56
mcevoli mcevoli is offline
Junior Member
 
Join Date: Jan 2012
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Default SuPHP and SSL issue

Hi,
I have a working vhosts setup with suphp configured.
I have one website (with joomla 2.5) using SSL.
Joomla seems not using suphp. I have no write permission on folders, but if I disable SSL I get the right permissions.

If I go to site information I can see the Server API is set to "Apache 2.0 Handler" while for the working suphp sites is set to "CGI/FastCGI", I don't' know if can be useful.

Thanks in advance for any help.

Marco
Reply With Quote
Sponsored Links
  #2  
Old 3rd January 2013, 16:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Can you post your vhost configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd January 2013, 17:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Suphp should not be used for joomla sites on ispconfig servers. better use php-fccgi and enable the suexec checkbox in the site settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 3rd January 2013, 17:25
mcevoli mcevoli is offline
Junior Member
 
Join Date: Jan 2012
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Default

My sites are working all ok but the one using SSL.

To enable SSL I didn't use the ispconfig ssl tab because I already had the files on old server.

So I added to ispconfig.vhost the following lines:
Code:
<VirtualHost *:443>
     SSLEngine On
     SSLProtocol all
     SSLCertificateFile /etc/pki/tls/certs/certificate.crt
     SSLCertificateKeyFile /etc/pki/tls/certs/private.key
     SSLCACertificateFile /etc/pki/tls/certs/intermediate.crt

     ServerAdmin webmaster@domainname.it
     ServerName domainname.it
     ServerAlias www.domainname.it
     DocumentRoot /var/www/domainname.it/web/
     ErrorLog /var/log/ispconfig/httpd/domainname.it/error.log

    <Directory /var/www/domainname.it/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client29/web32/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
	
	
 # Clear PHP settings of this website
    <FilesMatch "\.ph(p3?|tml)$">
        SetHandler None
    </FilesMatch>
    # suphp enabled
    <Directory /var/www/clients/client29/web32/web>
                <IfModule mod_suphp.c>
        suPHP_Engine on
        # suPHP_UserGroup web32 client29
        suPHP_ConfigPath /var/www/conf/web32
        AddHandler x-httpd-suphp .php .php3 .php4 .php5
        suPHP_AddHandler x-httpd-suphp
                </IfModule>
    </Directory>

    # add support for apache mpm_itk
    <IfModule mpm_itk_module>
      AssignUserId web32 client29
    </IfModule>

    <IfModule mod_dav_fs.c>
          # Do not execute PHP files in webdav directory
      <Directory /var/www/clients/client29/web32/webdav>
            <FilesMatch "\.ph(p3?|tml)$">
          SetHandler None
        </FilesMatch>
      </Directory>
      DavLockDB /var/www/clients/client29/web32/tmp/DavLock
      # DO NOT REMOVE THE COMMENTS!
      # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
      # WEBDAV BEGIN
      # WEBDAV END
    </IfModule>

</VirtualHost>
Thanks.
Reply With Quote
  #5  
Old 3rd January 2013, 18:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

Quote:
To enable SSL I didn't use the ispconfig ssl tab because I already had the files on old server.

So I added to ispconfig.vhost the following lines:
Ok, thats wrong and can not work. Please undo the changes you made manually.

Then enable ssl in the wesbite that shall have ssl access and create a new self signed certificate in ispconfig for that site. Test if the ssl cert works. Afterwards replace the .key and .cert file in the ssl folder of the site (folder /var/www/yordomain.tld/ssl/) with the key and ssl cert that you already have and restart apache. Dont change any filenames, just replace the key and cert data in the files.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
joomla, ssl, suphp

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSL and SuPHP tcn_dave Smalltalk 0 18th February 2011 01:07
suphp + ssl runs as www-data staatslot Installation/Configuration 6 22nd September 2010 15:47
chmod failure when switching from suPHP to fast-CGI Bookworm Installation/Configuration 4 18th August 2009 13:13
suPHP causing server 500 errors djh-compnet Installation/Configuration 7 11th July 2009 21:01
suPHP with SSL Norman General 2 17th June 2009 10:47


All times are GMT +2. The time now is 08:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.